Klingeltöne-Player aus Heft 7/2009 (090243)

Klingeltöne-Player aus Heft 7/2009 (090243)

Postby HaSch » Fri Feb 19, 2016 9:01 am

Hallo,

ich denke, dass mein Beitrag aus dem Unterforum "Meine Schaltung funktioniert (noch) nicht :-(" hier besser aufgehoben ist, weil das ein MC-Problem zu sein scheint und kein Problem des Schaltungsaufbaus.

Durch das Buch "311 Schaltungen" bin ich auf den Klingeltöne-Player aus Heft 7/2009 aufmerksam geworden und habe die Platine bestellt. Das Bestücken war kein großes Problem obwohl SMDs gelötet werden mussten. Als Prozessor habe ich den ATtiny13A genommen, der fast dieselben Werte wie der ATtiny13 hat und lediglich etwas genügsamer ist. Nachdem ich .hex- und .eep-File der runtergeladenen Software über AtmelStudio 6.2 auf den Prozessor geflasht hatte, musste ich leider feststellen, dass aus dem kleinen Schallwandler nur ein Geräusch kommt, das man beim besten Willen nicht als Klingelton identifizieren kann. Es ist so, als ob das in der Software vorgegebene Stück "Popcorn" viel zu schnell abgespielt wird. Am ehesten kann man es noch vergleichen mit dem Geräusch, das ein Faxgerät macht, das man versehentlich mit dem Telefon angewählt hat. Die Taktfrequenz des ATtiny13A ist wie im Artikel 9,6 MHz, ich denke nicht, dass es daran liegt. Fehler beim Compilieren können auch nicht dafür verantwortlich sein, weil ich ja die mitgelieferten fertigen Files genommen habe.

Was ist da los oder besser: Was muss ich machen, damit es funktioniert?

Gruß
Hans
User avatar
HaSch
 
Posts: 4
Joined: Thu Oct 16, 2014 9:24 am

Re: Klingeltöne-Player aus Heft 7/2009 (090243)

Postby albert » Wed Sep 21, 2016 3:23 pm

Hallo!
Hast du auch die Fuse Bit im ATtimy13A richtig eingestellt?
Der MC ist neu auf Int. RC Osc. 9,6MHZ...; Default value und Divide clock by 8 internally eingestellt.

mfg

Albert
albert
 
Posts: 106
Joined: Fri Jan 03, 2014 1:47 pm


Return to Elektor-Mikrocontroller-Forum

Who is online

Users browsing this forum: yahoo [bot] and 1 guest