Flowcode 4 servoansteuerung

Alles zum einsteigerfreundlichen Controllersystem

Postby golo100 » Sat Sep 29, 2012 12:00 am

hallo

ich wollte mir flowcode 5 zulegen weil mein freund und
ich einige Projekte realisieren wollen.
Er hat Flowcode 4.

Beim tetsten der servofunktion unter FC4 habe ich festgestellt
das,das Servo nur 90grad schwenkbereich hat obwohl es mehr kann
auch unter den einstellungen "trim" ergaben sich keine Änderungen.

das servo ist bei Byte = 0 schon fast halb ausgefahren.
bei Byte 255 kurz vor dem Ende.

was machen wir falsch
die funktion ist uns sehr wichtig.

Gruß Golo100
golo100
 
Posts: 4
Joined: Fri Jan 03, 2014 2:12 pm

Postby xsusakamei » Sat Sep 29, 2012 12:00 am

Hallo Golo100,

da Du leider überhaupt nichts davon geschrieben hast um welchen Prozessor & Hersteller es sich handelt ist es sehr schwer zu helfen. Ich habe aber mal kurz in der FC4 Demo(PIC) ein Servo angesteuert. In der Demo sieht man aber schon, daß es wirklich nur ca. 90° sind.

Da ich in der Demo von FC4 einige Probleme habe die "Hardware" auf dem Bildschirm anzeigen zu lassen(ich wähle z.Bsp. das PWM-Makro aus und dann finde ich das Fenster nicht mehr *confused*) konnte ich keine weiteren Tests durchführen.

Die Updatepolitik von MM sowie die vielen Fehler in FC finde ich sehr nervend und zeitintensiv, was mich auch dazu bewegt hat von FC3 auf C umzusteigen. Was ich Dir/Euch an dieser Stelle auch nur wärmstens empfehlen kann!!! Denn FC wandelt das "Programm" auch erst in C um, welches dann in HEX compiliert wird. Wesentlich effektiver und letztendlich schneller(und vermutlich billiger^^) wäre es, wenn Flowcode das Programm in Assembler umwandeln würde. Aber das ist ein anderes Thema.

Als Tip kann ich hier nur geben auf das Servo-Makro zu verzichten und stattdessen das PWM Makro zu nutzen! Sollte alles nicht funktionieren würde ich die Frage(auf englisch) im MM-Forum stellen.

Gruß
Jürgen
xsusakamei
 
Posts: 58
Joined: Fri Jan 03, 2014 2:02 pm

Postby golo100 » Sat Sep 29, 2012 12:00 am

hallo

Die FC4 ist keine Demo

der Prosessor ist ein Pic 16F876
golo100
 
Posts: 4
Joined: Fri Jan 03, 2014 2:12 pm

Postby xsusakamei » Sat Sep 29, 2012 12:00 am

Nun, das ist mir schon klar das Deine Version keine Demo ist - aber meine! Wer lesen kann ...

Da ich Dein Problem nicht 100%ig nachstellen kann hoffe ich, es kann ein anderer User helfen. Es gibt auch noch das MM(Matrix Multimedia) Forum!

Gruß
Jürgen
xsusakamei
 
Posts: 58
Joined: Fri Jan 03, 2014 2:02 pm

Postby golo100 » Sun Sep 30, 2012 12:00 am

hallo
erstmal vielen dank für die Antworten

ich versuche mich gerade daran den servo über PWM anzusteuern

allerdings bekomme ich bei PWM keine Periodenzeit von 20ms hin

max 4ms

gruß

golo100
golo100
 
Posts: 4
Joined: Fri Jan 03, 2014 2:12 pm


Return to E-blocks und Flowcode

Who is online

Users browsing this forum: No registered users and 0 guests

cron