Het Elektor forum gaat sluiten. Zie ook deze link. Vanaf vrijdag 15 maart is het niet langer mogelijk om in te loggen op het forum. Wel blijft de inhoud van het forum nog zichtbaar tot het einde van de maand maart. Per 1 april gaat het forum definitief uit de lucht.

Communicatie errors

Info over het uitlezen van RFID-kaarten

Postby remcohn » Thu May 31, 2007 12:00 am

Heb net mn RFID ontvanger binnen gekregen en getest...

Het probleem wat ik heb is dat is regelmatig de error:
'Read Page 0 to 3 <- Error: 0xF00 Incorrect Serial Frame' krijg. En daardoor word ook de kaar niet herkent.

Als ik het geheel opnieuw opstart en aan zet enzo, en ik doe 'HF reset', krijg ik:
RF RESET <- Error: 0xF00 Incorrect Serial Frame
'Doe ik het dan nog een keer, krijg ik 'RF RESET' zonder error verder (zoals het hoort denk ik)

Zijn er meer mensen die het zelfde probleem hebben en het mischien ook al opgelost hebben?

Remco
remcohn
 
Posts: 5
Joined: Thu Jan 02, 2014 3:34 pm

Postby ajstolk » Thu May 31, 2007 12:00 am

Ik heb het zelfde probleem. Via de PC heb ik dan ook nog geen kaarten kunnen uitlezen. Via het display wel. Ik heb wel gemerkt dat wanneer de voedingsspanning lager is dan 5,5 Volt, de lezer moeite heeft met opstarten en de kaart te herkennen. Met behulp van een labvoeding met een spanning van tussen de 5,5 en 6 Volt werkt het namelijk prima. Zou het kunnen dat de spanning vanuit de USB te laag is zodat de lezer niet opstart?

Arno
ajstolk
 
Posts: 1
Joined: Thu Jan 02, 2014 3:43 pm

Postby chrisvossen » Thu May 31, 2007 12:00 am

Hallo,

Ik heb in het lab geprobeerd om dit te reproduceren wat me niet gelukt is. Probeer eens een andere pc. We hebben ervaring dat sommige usb host controllers niet in staat zijn om voldoende vermogen te leveren. Wat eigenlijk wel zou moeten.

Mvg,

Chris
chrisvossen
 
Posts: 6
Joined: Thu Jan 02, 2014 3:27 pm

Postby Guest » Thu May 31, 2007 12:00 am

Jep net hetzelfde probleem enkel de weergave "Terminal" werkt, in de weergave "Mifare UltraLight" niks dan error: 0xF00 Incorrect Serial Frame. De weergave "Show all cards" werkt enkel als je éérst een bezoekje brengt aan de weergave "Access Control" De module "Acces Control" werkt helemaal niet.
Heb dit al op 3 verschillende PCs getest zonder resultaat, de firmware overladen met "Flash Magic" verloopt rimpeloos.
Ik gebruik WinXP SP2 incl. alle updates recentste drivers voor USB etc..'
Guest
 

Postby chrisvossen » Thu May 31, 2007 12:00 am

Hallo,

Het zou kunnen zijn dat de kristaloscillator fout staat ingesteld van jouw reader. Je schrijft dat je wel nieuwe firmware kan flashen dus je bent inmiddels al een beetje bekend met flash magic.
Start flashmagic weer op met de juiste instellingen: Deze zijn als volgt:

Comport: Select correct comport
Baudrate: 9600
Device: 89LPC936
Interface: None(ISP)
Oscillator: 16000000

Erase blocks used by Hex file should be checked
All the rest should be unchecked

Plaats de jumpers

Dat laatste is alleen nodig als je nieuwe firmware wilt flashen.
Kies vervolgens Device configuration. Dit knopje zit ongeveer in het midden. Controleer vervolgens of de oscillator op de HC 4Mhz-12Mhz staat. Als hij op internal staat dan gaat je usb niet werken. De baudrate is dan foutief.

Suc6 ermee.
chrisvossen
 
Posts: 6
Joined: Thu Jan 02, 2014 3:27 pm

Postby Guest » Thu May 31, 2007 12:00 am

neen, heb dit gedaan volgens hierbovenvermelde instructies zonder resultaat, één foutje de baudrate in Flash Magic stond ingesteld op 7200 dit moest dus 9600 zijn de rest is ok, het flashen zelf verloopt prima maar als ik de jumpers verwijder ben ik terug naar af.
Het valt mij wel op dat bij "Mifare Magic" weergave "Mifare UltraLight" de LCD display van de reader de volgende tekst vertoont;

|||PC||Mode||||||||||||||
|||PC:115200||Bd|||||||||

Zou het kunnen dat ons Kristal en haar vriend Oscillator doof is?
Guest
 


Return to 2006-09 RFID uitlezen

Who is online

Users browsing this forum: No registered users and 0 guests