LEDCube 5x5x5 (080355)

Postby mr beamer » Thu Jan 01, 2009 12:00 am

Ik heb er al 1 effect bij gemaakt.
Een random led effect.
Eerst wordt er 100x een random led aan en uit gezet.
Dan worden er random 100 led's aan gezet.
Daarna worden er weer 100 led's aan en uit gezet.
(Stond deze led al aan dan wordt deze uit gezet.
Stond deze niet aan dan flitst deze 1x.)

http://www.youtube.com/watch?v=XfNDJC-4RAM
http://www.youtube.com/watch?v=T2VAyKAI-6c
http://www.youtube.com/watch?v=a1CivKAd8Ys





Zoals je ziet heb ik de basis weerstanden van de transistors vervangen door de smd variant.
Tevens heb ik voor AL de transistors de BC547 gebruikt. T1..T5 blijken het nog goed te blijven doen al is de piek stroom wel boven spec.
En in de voeding heb ik de onderdelen weg gelaten die bij een externe gestabiliseerde 5v voeding niet nodig zijn.'
Attachments
randomeffect.txt
(501 Bytes) Downloaded 90 times
mr beamer
 
Posts: 6
Joined: Thu Jan 02, 2014 3:42 pm

Postby jerryjacobs » Thu Jan 01, 2009 12:00 am

Kijk dat ziet er ook schoon uit,
Ik weet niet of je msn of mail hebt maar je kunt contact met mij opnemen en kunnen samen de firmware verbeteren.

In de firmware html staat mijn email adres

Groeten,
Jerry

P.s ik krijg de rand() functie niet goed werkend zonder avrstudio of gebruik je ook gewoon de makefile ?
jerryjacobs
 
Posts: 8
Joined: Thu Jan 02, 2014 3:42 pm

Postby mr beamer » Thu Jan 01, 2009 12:00 am

Ik heb zelf nog bijna geen ervaring met AVR of C

Ik heb ook nog niet echt naar de rest van de firmware gekeken dus ik kan ook nog geen eventuwele verbeteringen aanbevelen.
Als ik iets vind zal ik wel contact opnemen.

Ik gebruik inderdaad avrstudio zonder makefile

Ik weet niet of je er iets aan hebt maar dit is mijn geexporteerde makefile

Ik zie trouwens wel iets raars
De eerste keer dat hij zijn programma doorloopt (na reset) knipperen de eerste kolom leds af en toe op een rare manier.
Net of er ergens een variabele niet goed staat.
Heeft hij zijn complete programma afgerond, dan is de knippering weg.
mr beamer
 
Posts: 6
Joined: Thu Jan 02, 2014 3:42 pm

Postby jerryjacobs » Thu Jan 01, 2009 12:00 am

Ik heb het nu werkend gekregen, het probleem is de opties die je de compiler moet meegeven wat hij moet doen met compileren. Dit heb ik gedaan met avrstudio en gekeken met welke opties hij die doet compileren.
jerryjacobs
 
Posts: 8
Joined: Thu Jan 02, 2014 3:42 pm

Postby jean-pierre de muyt » Fri Jan 02, 2009 12:00 am

Ik ben alvast wat slimmer geworden: JTAG disabled en alles werkt nu prima. Alvast van harte bedankt!
In afwachting van mn aanscherpen van eigen C++ kennis om zelf de source code aan te passen en te hercompileren: is er iemand die bereid is om aangepaste sourcecode met leuke effecten te delen?
jean-pierre de muyt
 
Posts: 4
Joined: Thu Jan 02, 2014 3:42 pm

Postby jerryjacobs » Fri Jan 02, 2009 12:00 am

C en C++ is nogal een groot verschil.
De code die erbij is geleverd bevat al reeds voorbeelden en ook een "lowlevel driver" voor het makkelijker maken van het aanzetten en uitzetten van leds/kolommen etc.

Je kunt ook contact me me opnemen op mijn mail adres.
Deze zit in AUTHORS.txt in de broncode.

Groeten,
Jerry
jerryjacobs
 
Posts: 8
Joined: Thu Jan 02, 2014 3:42 pm

Postby jean-pierre de muyt » Fri Jan 02, 2009 12:00 am

Ik ben alvast wat slimmer geworden: JTAG disabled en alles werkt nu prima. Alvast van harte bedankt!
In afwachting van mn aanscherpen van eigen C++ kennis om zelf de source code aan te passen en te hercompileren: is er iemand die bereid is om aangepaste sourcecode met leuke effecten te delen?
jean-pierre de muyt
 
Posts: 4
Joined: Thu Jan 02, 2014 3:42 pm

Previous

Return to 2008-12 LED kubus

Who is online

Users browsing this forum: No registered users and 1 guest