!! Achtung: Schwarze Balken auf dem Display !!

Postby klaus boda » Wed Jul 10, 2013 12:00 am

Hallo Roland,

besagten Herrn Berg erreichst Du nicht?
Gerade dieser müsste doch über mehrere Fehler-Rückmeldungen und evtl. Software/Hardwarefehler Bescheid wissen.

Wäre sicher in diesem Fall hilfreicher als die Elektor-Redaktion.

Ich denke ich verstehe, was Du meinst, wenn Du sagst, das LCD müsste auch bei Lektion 5 funktionieren, auch wenn der Kurs noch früher dran ist.
(Hoffe ich habe das richtig verstanden) - Wer macht das nicht, bei einem Lernpaket oder so gleich mal was von Kapitel XX zu bauen, weil einen da was interessiert.

Nun bin ich aber wieder bei der Software... werden vielleicht irgendwelche libs, und wie die Komponenten alle heißen, vorher eingebunden?

Ich sehe schon, als Außenstehender ist das in etwa so, als ob Du mich anrufst und sagst "Mein Auto geht nicht mehr" und ich reite dauernd auf "Zylinderkopfdichtung" herum, ohne Irgendwas zu wissen

Also Herr Berg wäre sicher die Top-Ansprechperson.

Wenn Du Da was erreichst, wäre es echt interessant zu wissen, also immer her mit seinen evtl. Lösungen bzw. defekten Bauteilen.

Bauteilsuche ist ja wieder ein eigenes (meist leichtes) Problem.

Blöd wirds, wenn es da um SMD-Teile geht, die auch noch auf mehrlagiger Platine sitzen, dann reden wir vom Umbau.

Jedoch, wenn da allgemein etwas defekt ist, müsste das doch auf Garantie gehen.
Ich weiß nicht warum, aber mich interessiert das Thema jetzt bis zur Lösung.

LG Klaus
klaus boda
 
Posts: 120
Joined: Thu Jan 02, 2014 10:49 am

Postby dero » Wed Jul 10, 2013 12:00 am

wenn ich was weiß, geb ich hier Bescheid.

Das mit dem Bauteil, so denke ich, ist nicht so einfach.
Nach meinen heutigen Messungen, müsste das der GAL16V8 sein. Das ist eine programmierbare Logik mit ein/-Ausgängen. Dafür bräuchte man noch ein Brenngerät oder ähnliches (davon hab ich keine Ahnung) und das Programm selber, das dann die NAND-Gatter usw. schaltet.

Ja, Garantie dachte ich auch!

Wenn nichts hilft, muss ich wohl oder übel das ganze Board einschicken und darauf hoffen, daß es nicht so teuer wird.


Gruß Roland
dero
 
Posts: 17
Joined: Fri Jan 03, 2014 1:58 pm

Postby ag » Wed Jul 10, 2013 12:00 am

Hallo Roland,

ich habe mir den Schaltplan angesehen, und hätte daraufhin auch auf entweder die GAL16V8 oder die 74HC573 geraten.

Da du mit der GAL16V8 wegen die Programmierung eher schlechte Karten hast, hätte ich nach dem Prinzip "einfachste und billigste Lösung zuerst versuchen" empfohlen, zuerst die 74HC573 zu ersetzten. Dabei gehe ich aber davon aus, dass, wie im technische Unterlagen empfohlen, die ICs auf deinem Board gesockelt und nicht gelötet sind.

Will auch niemand vorgreigen

Viele Grüße,
Ag
Ag
ag
 
Posts: 532
Joined: Thu Jan 02, 2014 10:37 am

Postby dero » Thu Jul 11, 2013 12:00 am

Guten Morgen Ag,

danke für die Gedanken, kann dir aber nicht ganz folgen.

Was hat der 74HC573N mit der Verbindung zum LCD zu tun?
Laut meinem Schaltplan gehen die Pins 30-37 vom µC über den 74HC573N auf die Steckerleiste X2, wo sie später die Peripherie von der Erweiterung anschließt.

Deswegen tippe ich sehr stark auf den GAL.


Mfg Roland
dero
 
Posts: 17
Joined: Fri Jan 03, 2014 1:58 pm

Postby bvb » Thu Jul 11, 2013 12:00 am

Hallo Roland,
wir können Dir ein neues GAL zusenden.
Besser ist es aber, wenn Du uns das Board zusendest und wir prüfen/reparieren es kostenfrei. Nach 3-4 Tagen hast Du das Board zurück.

Viele Grüße

Bernd
bvb
 
Posts: 190
Joined: Fri Jan 03, 2014 1:53 pm

Postby dero » Thu Jul 11, 2013 12:00 am

Guten Morgen,

ich weiß nicht, ob du alle Beiträge gelesen hast! Bei mir liegt ja der Fall so, daß ich das Board über die SGD erhalten habe. Ich habe mich bei "Elektor" angemeldet, weil ich wissen wollte, ob noch mehr Leute das Problem haben.

Die SGD möchte aber für die Reperatur Geld sehen.
Wenn ich das nämlich gewußt hätte, hätte ich den Lehrgang über Elektor gemacht

Geht das dann ohne Weiteres, das Board zu Euch zu schicken und ihr repariert es?
Wo müsste ich das Board hinsenden?

Das wäre natürlich super!!!!!!!


MFG

Roland
dero
 
Posts: 17
Joined: Fri Jan 03, 2014 1:58 pm

Postby dero » Thu Jul 11, 2013 12:00 am

Noch ne Frage,

müsste ich eigentlich nicht den Adressen-Bereich der C/S-Logik umprogrammieren können?
Jetzt ist ja das CS_LCD im Adress-Bereich oxf400-0xf7ff.
Wenn ich jetzt den PT-Core One ohne zusätzliche Peripherie(Board TFH-BBO One) betreibe, sind doch eigentlich die Adress-Bereiche CS0-CS3 frei,oder?
Dann könnte ich doch z.B. mit Adressänderung von 0xf400 auf 0xe00 und die Pin_belegung von Pin 14 auf Pin 12 realisieren.

Müsste dann das LCD funktionieren?

LG Roland
dero
 
Posts: 17
Joined: Fri Jan 03, 2014 1:58 pm

Postby ag » Thu Jul 11, 2013 12:00 am

DeRoGuten Morgen Ag,

danke für die Gedanken, kann dir aber nicht ganz folgen.

Was hat der 74HC573N mit der Verbindung zum LCD zu tun?
Laut meinem Schaltplan gehen die Pins 30-37 vom µC über den 74HC573N auf die Steckerleiste X2, wo sie später die Peripherie von der Erweiterung anschließt.

Deswegen tippe ich sehr stark auf den GAL.


Mfg Roland


Hallo Roland,

ich habe gesehen, das Busleitungen A0 und A1 von Pin 19 und 18 der 74HC573 zu Pin 4 bzw. 5 von X8 führt. Deshalb der "einfach und billig zuerst". Ich wollte nicht so tief hineinsteigen, um auswerten zu können, was Pins 4 und 5 an Bedeutung für das LCD hat (falls überhaupt), denn das würde (für mich) der Aufwand des Austauschs schon übersteigen

Da es aber offenbar kein Problem ist, eine programmierte GAL zu bekommen, mag das wohl nicht der schlechtere Ansatz sein.

Wie auch immer, wünsch ich dir viel Erfolg

Viele Grüße,
Ag
Ag
ag
 
Posts: 532
Joined: Thu Jan 02, 2014 10:37 am

Postby bvb » Sun Jul 21, 2013 12:00 am

Hallo Roland,
das Board ist repariert worden und wieder auf dem Weg zurück zu Dir.

Viele Grüße

Bernd
bvb
 
Posts: 190
Joined: Fri Jan 03, 2014 1:53 pm

Postby dero » Mon Jul 22, 2013 12:00 am

Guten Morgen Bernd,

ich bedanke mich recht herzlich bei dir für den unkomplizierten Weg ein funktionierendes Board zu erhalten.

Ich kann und werde den Fern-Lehrgang über Elektor und die Firma PalmTec weiterempfehlen.
Das Board wurde innerhalb einer Woche wieder funktionsfähig gemacht.


Danke nochmal

LG Roland
dero
 
Posts: 17
Joined: Fri Jan 03, 2014 1:58 pm

Previous

Return to Mikrocontroller-Fernlehrgang (TFH)

Who is online

Users browsing this forum: No registered users and 1 guest