Fehler - Flip Exception Stack

Postby d.petig » Tue Jan 15, 2008 12:00 am

Hallo,
ich erhalte im Amtel Flip nach dem Durchlauf des Blank Check, also beim Begin der Programierung ein Hinweisfeld (Flip-Exception Stack) mit der Fehlermeldung java.lang.NullPointerException.

Danach passiert nichts mehr der Programiervorgang wird abgebrochen. Auf dem Display sind nur noch die Zeilen 1 und 3 schwarz. Auch beim Laden von prog_1hex geschiehrt das gleiche.

In HyperTerm erscheint auch nichts mehr. Die serielle verbindung funktioniert jedoch.

Kann jemand helfen?
d.petig
 
Posts: 2
Joined: Fri Jan 03, 2014 2:12 pm

Postby μtronix » Tue Jan 15, 2008 12:00 am

Hallo,

Deinen Angaben zufolge setzt Du bereits die Version 3 von FLIP ein. Diese basiert auf Java, weshalb geprüft werden sollte, ob eine aktuelle Java-Version von SUN installiert ist. Downloadbar ist diese von http://java.sun.com.
Alternativ ist bei ATMEL auch eine Version mit der Java-Laufzeitumgebung verfügbar:

http://atmel.com/dyn/resources/prod_documents/JRE-Flip_Installer-3-2-2.exe

In dem Lehrgang wird primär die auf der mitgelieferten CD enthaltene Version 2.x.x für Windows-Systeme benutzt:

http://atmel.com/dyn/resources/prod_documents/flip-2_4_6.zip

Sollten sich die Probleme mit der Installation/Aktualisierung der Java-RE(JRE) nicht lösen lassen, könntest Du die o.g. Version 2.4.6 verwenden, um den Mikrocontroller zu programmieren.

Gruß,
Patrick
μtronix
 
Posts: 197
Joined: Fri Jan 03, 2014 2:12 pm

Postby d.petig » Fri Jan 18, 2008 12:00 am

Hallo Patrick,
durch Deinen Hinweis bin ich weitergekommen.
Meine Java Variante verursachte dies tatsächlich.
Flip 3 ist jetzt wieder funktionsfähig.

Danke
Dirk
d.petig
 
Posts: 2
Joined: Fri Jan 03, 2014 2:12 pm


Return to Mikrocontroller-Fernlehrgang (TFH)

Who is online

Users browsing this forum: No registered users and 1 guest