Laatste firmware source

Laatste firmware source

Postby xjmaas » Thu Jun 04, 2015 8:07 am

Tijdens de beurs werd aangegeven dat 's ochtends de laatste firmware was verspreid. Graag zou ik hier de source van willen kunnen downloaden, zodat ik de e-brace opnieuw kan flashen
xjmaas
 
Posts: 3
Joined: Thu Jun 04, 2015 6:56 am

Re: Laatste firmware source

Postby MaartenMeta » Fri Jun 05, 2015 8:38 am

Op http://www.metatronics.nl/e-brace is de laatste software te vinden samen met de handleiding.
In de handleiding staat alles beschreven over de mogelijkheden van de e-brace
Bij de bestanden op de website zit ook de PC applicatie die op de beurs gebruikt is met een speciale handleiding.
Hierdoor kan iedere e-brace gebruiker zelf een ID instellen in de e-brace.
MaartenMeta
 
Posts: 19
Joined: Fri Jun 05, 2015 8:18 am

Re: Laatste firmware source

Postby MaartenMeta » Fri Jun 05, 2015 1:22 pm

De nieuwe software is te vinden op http://www.metatronics.nl/e-brace hier is ook de PC applicatie te vinden.
Deze PC applicatie is gebruikt op de beurs om de e-brace een ID te geven.
MaartenMeta
 
Posts: 19
Joined: Fri Jun 05, 2015 8:18 am

Re: Laatste firmware source

Postby Roberto48 » Fri Jun 05, 2015 2:22 pm

Ik heb de laatste firmware (main_program) geladen en daarna werkte hij niet meer...posting.php?mode=reply&f=2698582&t=2715741&sid=57ba359c9e157f4f9df8d85122a796bc#
Daarvoor nog de vorige versie geladen en dat ging probleemloss.
Toch nog een foutje in de firmware?
Roberto48
 
Posts: 6
Joined: Fri Jun 05, 2015 2:17 pm

Re: Laatste firmware source

Postby Roberto48 » Fri Jun 05, 2015 5:42 pm

Het laden van de laatste firmware (main_program van 5/5/2015) die nu op de site staat heeft bij mij geresulteerd dat de e-brace niet meer werkt.
Ik hoor geen start muziekje meer en ook schudden heeft geen zin. Wel gaat op een gegeven moment het groene LED-je branden en naar verloop van tijd weer uit.

De vorige versie die op de site stond werkte wel. Nal laden werkte alles zoals ik de e-brace ook had ontvangen, dus met intro muziekje.
Ook de PC applicatie die nu op de site staat werkt ook niet. Krijg bij opstart al een foutmelding nadat ik het xml document heb geselecteerd (Windows 7).

Dus graag de vorige versie van de firmware weer terug zetten of deze versie repareren. Helaas heb ik de oude versie niet bewaard....
Roberto48
 
Posts: 6
Joined: Fri Jun 05, 2015 2:17 pm

Re: Laatste firmware source

Postby Tronics » Fri Jun 05, 2015 8:53 pm

Heb je hier al gekeken?

http://www.metatronics.nl/project/e-bra ... eurs-2015/

Succes,
Tronics
Tronics
 
Posts: 3
Joined: Fri Jun 05, 2015 8:46 pm

Re: Laatste firmware source

Postby Roberto48 » Mon Jun 08, 2015 8:41 am

Ja, die software had ik geladen...
Maar ik ben er nog eens ingedoken (moet nog wennen aan de Arduino prgramma structuur) en zag dat het geluid in de laatste versie was 'uitgesterd'.
Na dat weer hersteld te hebben kwam ook weer het bekende geluidje en bleek alles gewoon te werken posting.php?mode=reply&f=2698582&t=2715741#

Ook eens wat andere (Adafruit) programma's in de Atmel geladen en die werkten ook direct. Dus al met al een leuke ontwikkel set met handige extra modules!
Goeie keus geweest om me in te schrijven voor de e-brace!
Roberto48
 
Posts: 6
Joined: Fri Jun 05, 2015 2:17 pm

Re: Laatste firmware source

Postby MaartenMeta » Mon Jun 08, 2015 11:31 pm

Het geluidje is inderdaad uitgecomment in de nieuwe versie, vooral om er niet gek van te worden :)
Het groene LEDje gaat branden als er een handshake gedaan is.
Er is een "probleem" in de hardware gevonden, de controller komt een rare mode als de USB kabel aangesloten is maar de schakelaar de module uitzet.
Er loopt via de TX van de FTDI een spanning naar de microcontroller, deze spanning is rond de 1.2V hier raakt de microcontroller van in de war.

Maar ook de accelerometer, waarbij in de datasheet staat aangegeven dat deze goed werkt als hij vanaf 0V opstart.
Dus start de e-brace altijd door hem aan te zetten en dan de batterij aan te sluiten en daarna de USB kabel.
Op deze manier is zeker dat de module goed opstart.
MaartenMeta
 
Posts: 19
Joined: Fri Jun 05, 2015 8:18 am

Re: Laatste firmware source

Postby Roberto48 » Tue Jun 09, 2015 8:11 am

Hallo Maarten,

Dat dacht ik al dat dat de reden was dat het geluidje uit was gezet. Als je aan het testen bent wordt dat irritant haha!

Wat je laatste opstart opmerking betreft: Daar was ik ondertussen ook achter gekomen nadat ik er andere firmware in had geschoten.
Dat wilde ook niet altijd starten als de USB kabel nog was aangesloten.

Volgende test wordt het laten werken van een OLED display via I2C. Zal zeker ook wel lukken...

Dankzij jullie e-brace heb ik er weer een leuk ontwikkel platform(pje) bij en doe een hoop Arduino kennis op!

Groet,
Rob
Roberto48
 
Posts: 6
Joined: Fri Jun 05, 2015 2:17 pm


Return to E-brace E&A-beurs 2015

Who is online

Users browsing this forum: No registered users and 1 guest