Het Elektor forum gaat sluiten. Zie ook deze link. Vanaf vrijdag 15 maart is het niet langer mogelijk om in te loggen op het forum. Wel blijft de inhoud van het forum nog zichtbaar tot het einde van de maand maart. Per 1 april gaat het forum definitief uit de lucht.

bootloader met arduino

Elektor- en lezersprojecten met een Arduino

bootloader met arduino

Postby jawiko » Wed Nov 26, 2014 1:24 pm

Ik heb op een arduino-uno een amega328P-P van een bootloader voorzien volgens de methode beschreven in http://arduino.cc/en/Tutorial/ArduinoToBreadboard# en http://arduino.cc/en/Tutorial/ArduinoISP.
(Methode breadboard). De laatste stap bleek vooraf te moeten gaan met op de tab extra eerst programmer>arduino-as-ISP aan te vinken voordat onder de zelfde tab bootloader-branden iets opleverde. Na misschien nog geen minuut knipperende LED's gaf het programma aan dat de bootloader was geladen.
Om het resultaat te testen heb ik amega328P-P uit de arduino-uno vervangen door het nieuw gebrande exemplaar. Daarna een hexfile van een scetch van slechts enkele regels geprobeerd naar de arduino-uno te schrijven. Dat leverde:
avrdude: stk500_getsync(): not in sync: resp=0x00.
Zowel voor als na deze proef leverde de arduino-uno met de originele amega328P-P wel een goed resultaat op.
Vraag is: Wat staat verkeerd in de aanwijzingen voor het branden van een bootloader, of wat deed ik verkeerd, of hoe krijg ik de melding avrdude: stk500_getsync():... weg?
jawiko
 
Posts: 5
Joined: Tue Nov 25, 2014 6:03 pm

Return to Arduino

Who is online

Users browsing this forum: No registered users and 1 guest