Labworx 2, Ring light is not working

The book series by Vincent Himpe

Labworx 2, Ring light is not working

Postby gerritpostma » Sun Jan 04, 2015 9:32 pm

Hello,


My knowledge of electronics is limited and the exercises in "Mastering SMT" are my first experiences with SMD. The book is great.
The "Led Tester" does not work, but that was due to starters errors. For "Ring light" i had a higher expectation. Done with "Solder paste" and a hot air station and the result looked promising though a magnifier. But no light after powering it with a 5v dc (K1).
- When 5V is adjusted over two leds, then both LEDs give light. Same for the other 18*2 LED combinations.
- Tests with a multimeter does not show shortcuts.

Any suggestion how to continue?

Regards gerrit
gerritpostma
 
Posts: 7
Joined: Fri Jul 18, 2014 8:12 pm

Re: Labworx 2, Ring light is not working

Postby gerritpostma » Mon Jan 05, 2015 9:31 am

Added picture of the mainpart.

C9 maybe connected to C11, but that is to the same wire.
Attachments
mainpart.JPG
mainpart picture
gerritpostma
 
Posts: 7
Joined: Fri Jul 18, 2014 8:12 pm

Re: Labworx 2, Ring light is not working

Postby ag » Mon Jan 05, 2015 5:20 pm

Hi Gerret,

I found at least 3 others who built this ring light who reported problems (in the german forum). The problems appear to have been due to wrong microcode programmed into the PIC12F683. In the following link you can find pictures of the signal on pin 2 of U2 which show the incorrect signal due to the incorrect firmware. If you have an oscilloscope, you should check your pin 2 signal, and if it is similar to that in the pictures, you also have received a PIC12F683 with incorrect firmware. In that case, you might be able to return your ring light to Eurocircuits for a no-cost repair, as at least one customer in the cited link did.

viewtopic.php?f=167773&t=2507995

Regards,
Ag
ag
 
Posts: 531
Joined: Thu Jan 02, 2014 10:37 am

Re: Labworx 2, Ring light is not working

Postby gerritpostma » Wed Jan 07, 2015 12:06 am

Hello Ag, Thanks for your search and your suggestions.

Presumably my idea about the exercises in the book was to basic. I expected just to learn soldering techniques. The good thing about a not working system is, that it is a start for learning more. I ordered an adapter for storing software on a PIC device. This adapter is also needed for the first book “Mastering the I2C”. The german site has also the same doubts that 5V power is not enough.
I am a starter and the problem is, that I don't know what to expect when testing a board and also the possibility to blowup a device. Diagrams don't show what one should measure as input/output of every device. Anyway the german site give some suggestions for testing. I will post any progress.

Gerrit
gerritpostma
 
Posts: 7
Joined: Fri Jul 18, 2014 8:12 pm

Re: Labworx 2, Ring light is not working

Postby gerritpostma » Sun Jan 18, 2015 7:33 pm

U1: PIC12F683: Ordered a pic adapter and compared the loaded software and software accoording the book. The first 4 bytes were different
U2: MIC3289: replaced with a new one
Used an other adapter with a higher current output; 5V - 2A

Result: the leds give light now (very bright).
-switch 1 for power on/off is working
-switch 4 for memory: ???. Light is out during button is pressed
-switch 2 for light up step: does not work
-switch 3 for light dimming : does not work and light is out during button is pressed

Intermediate result: lights are working. Next step is again investigating PIC12F683
gerritpostma
 
Posts: 7
Joined: Fri Jul 18, 2014 8:12 pm

Re: Labworx 2, Ring light is not working

Postby gerritpostma » Mon Jan 19, 2015 3:19 pm

It is now working.

Used a new PIC12F683 and played a bit with the pk2cmd and Diamex PICkit2 tool.
The pk2cmd never returns a error. Without an installed pic in the tool, even then there is no error and all commands still give some output files and so on.
The first important command should be:
pk2cmd -P
This investigates the PIC and returns the type. So, I finally find out that all the time the pic was installed in the wrong direction (pin1 was pin8).
After that it was easy to store the hex ringlight file from the labworx site.

Did some tests with the original PIC12F683 of the ringlight kit. The investigation did not return the type. Presumably the pic was damaged during the several occasions of desoldering and soldering .
gerritpostma
 
Posts: 7
Joined: Fri Jul 18, 2014 8:12 pm

Re: Labworx 2, Ring light is not working

Postby Elektor Editor » Fri Feb 27, 2015 9:27 am

thank you gerrit for posting your faultfinding experience in such a candid way. Glad to see it works now.
Topic closed.

Jan
Elektor Editor
 
Posts: 466
Joined: Thu Jan 02, 2014 10:36 am


Return to LabWorX

Who is online

Users browsing this forum: No registered users and 2 guests

cron