The Elektor Forum will close. See also this link. From Friday March 15st it is no longer possible to log in to the forum. However, the content of the forum will remain visible until the end of March. As of April 1st the forum will definitely go off the air.

LCR meter Power Supply

Equipment, circuits, projects, procedures

LCR meter Power Supply

Postby wo » Wed Mar 19, 2014 3:58 pm

Dear Jean-Jacques,


Thank you for answering my bootloader question in the other topic. So far it works good
but a small problem is remaining.

When powering up on a notebook USB there’s no problem to operate it
‚stand allone‘ or by the AU2011V300 program.

But when I tried to connect the LCR meter to an external USB power supply
it does not power up, the display remains dark.

At the power supply there are only the USB lines +5V (measured 5.15V) and GND connected, D+ an D- are open.

According to the Elektor article it should power up automatically in this case.

- Does the FT232 require at least a reaction of an installed PC driver to set the PWRN to HIGH ? (Table 3 in Elektor article 1 for ‚stand allone‘)

- must there be any level on D+/D- ?

- Does the microcontroller receive wrong signals to switch on the display ?




Thank You in advance
Wolfgang
wo
 
Posts: 2
Joined: Thu Mar 13, 2014 10:23 am

Re: LCR meter Power Supply

Postby snoopy_94 » Wed Mar 19, 2014 5:11 pm

Hello Wolfgang,

I have five USB power supply:
- Apple iPhone
- Wiko smartphone
- Huawei smartphone
- Panasonic camera
- No Name

All works fine!
On two of them, I measure a voltage of about 2 volts on the D+ and D- lines. On the other, no voltage, but the D+ and D- lines are interconnected.
It seems that the D+ and D- lines should not be open, so that the FT232R put the SLEEP line level high, and allows the voltage regulator to start.

Jean-Jacques
snoopy_94
 
Posts: 90
Joined: Thu Jan 02, 2014 10:48 am

Re: LCR meter Power Supply

Postby wo » Fri Mar 21, 2014 9:49 am

Hello Jean-Jacques,

Connecting D+ and D- (without any voltage level) makes it work !

Thank You
Wolfgang
wo
 
Posts: 2
Joined: Thu Mar 13, 2014 10:23 am

Re: LCR meter Power Supply

Postby gmessag » Tue Jul 15, 2014 1:50 pm

Hi,

I am mounting mi LCR meter. I'm newbie with smd an so for safer realization, i have just welded the power devices and the FTDI driver on the board.

I started with the same problem than explained earlier with the sleep signal that was locking the power devices (at first i pluged my board on my PC, windows fonded and install the ftdi driver, but the device remained in sleep mode; secondly i plugged my board on usb phone loader and same as first, ftdi driver remained in sleep mode; finally i found an other phone loader and it works).
Now i started to verify my power levels and i fond the TP13 at -16V !!! I tasted most of all the active parts and resistive bridges and didn't found any explanation at this level that should be -4.6V.
Rem the TP12 is at 4.3V and U15 is hot but the -16V of the buck inverter can explain it.

Is any body having an idea ?
gmessag
 
Posts: 15
Joined: Mon Jan 20, 2014 8:06 am

Re: LCR meter Power Supply

Postby gmessag » Tue Jul 15, 2014 3:15 pm

I Found the bug.

It was the Tantalum Cap C70 that was out. I replaced it and it works well. So i can continue the building.
gmessag
 
Posts: 15
Joined: Mon Jan 20, 2014 8:06 am

Re: LCR meter Power Supply

Postby Elektor Editor » Thu Jul 17, 2014 7:33 pm

We thank all contributors. Considering all questions have been answered this topis is closed.

Jan
Elektor Editor
 
Posts: 467
Joined: Thu Jan 02, 2014 10:36 am


Return to Test & Measurement

Who is online

Users browsing this forum: No registered users and 2 guests