radiation meter November 2011

Equipment, circuits, projects, procedures

Postby thijsbeckers » Mon Dec 02, 2013 12:00 am

On page 3 of this tread I posted a photo of our test enclosure, a can for 'Jodenkoeken'. On page 4 there's another sturdy enclosure.

In short: make sure the sensor is absolutely shielded from light and that the case is grounded properly to the gnd of the circuit.
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby sepp » Mon Dec 02, 2013 12:00 am

Ok that is good news.
I installed the sensor in a plastic tube, thought I didn't have to shield it in plastic - Wrong thinking?

Will try a different holder.

Thanks Thijs.
sepp
 
Posts: 8
Joined: Thu Jan 02, 2014 10:47 am

Postby thijsbeckers » Mon Dec 02, 2013 12:00 am

You could try a bigger resistor value, or a pot to correct the contrast.

Ok, so the counting part works ! Did you shield the sensor properly?
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby thijsbeckers » Tue Dec 03, 2013 12:00 am

Sepp...but one of the pins of the diode broke during process.

That's too bad. But luckily the BPW34 isn't expensive .

You do know the shorter the leads between sensor and FET are, the better!? Perhaps shielded (coax) cable will work (better). We havent tried that.'
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby sepp » Thu Dec 05, 2013 12:00 am

Ok, I'm back with some testing. The pot needs about 700 Ohm to have a good contrast, quit a difference from the 100Ohm.
Is this normal?

Still have the same problem with the counter, keeps on integrating.
Tried several things.
* new shielded cable and sensor holder (alu tube) + connected to mass.
* cookie box, same set up as page 3
* wrapped the whole thing in plastic and did some aluminium foil around it - connected to mass.

Could it be, I messed up the components?
(I doubt it cause I had everything taped on a sheet of paper and wrote every value under the components)


if not shielded from light: 0 counts
if shielded from light: integrating fast.
sepp
 
Posts: 8
Joined: Thu Jan 02, 2014 10:47 am

Postby thijsbeckers » Fri Dec 06, 2013 12:00 am

I would say, if 700 Ohms yields a good contrast, then use 700 Ohms. It's a bit high, but there's always something called 'tolerances'.

It looks like your circuit is working. What you're describing-not shielded: 0 counts, shielded: counting fast-looks like 'normal' operation. Our prototypes show the same behavior. The amplifier gets overloaded when light hits the sensor and the microcontroller doesn't count.

It looks like there's something else going on. How have you powered the circuit? I saw a 9V battery in one of your photos. Try a (lab) power supply or a wall wart for a change, see if that gets you some different results. Also, are you sure all ground connections are firm, and also, for example the cookie box had a firm connection to the circuit's ground? I've noticed some of those can have an isolating coating which needs to be scratched away before you can touch the metal with a wire...
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby sepp » Wed Dec 11, 2013 12:00 am

Hey,
Tried with a wall wart, no change.
I had only the 'sensor-unit' in a box, and had the idea it was much better, but not yet what it supposed to be.
So I decided to make a hole in the case so the display sticks out the box. Have the thing nicely shielded from any light.
Ground has a good connection with the box. (sanding paper and soldered)
It was back to worse.
Was afraid that the red led might interfere? To be sure it didn't I removed the led. - no change

Should the Photodiode be shielded and grounded seperately? even if there is no light and the whole thing is inside a shielded box?

Gr,
sepp
 
Posts: 8
Joined: Thu Jan 02, 2014 10:47 am

Postby thijsbeckers » Wed Dec 11, 2013 12:00 am

SeppHey,
Tried with a wall wart, no change.
I had only the 'sensor-unit' in a box, and had the idea it was much better, but not yet what it supposed to be.
So I decided to make a hole in the case so the display sticks out the box. Have the thing nicely shielded from any light.
Ground has a good connection with the box. (sanding paper and soldered)
It was back to worse.
Was afraid that the red led might interfere? To be sure it didn't I removed the led. - no change

Should the Photodiode be shielded and grounded seperately? even if there is no light and the whole thing is inside a shielded box?

Gr,

The display could be interfering, I don't believe its case is completely closed so it could be possible the light of the backlight is getting out.
It shouldn't be necessary to shield the diode separately. I couldn't deduct it from your description, but did you separate the sensor board from the main pcb and just put the sensor board in the shielded case? That's how we tested it.
The sensor board is VERY sensitive. No mobile phones, CRT monitors, (switching) power supplies in the neighborhood?
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby sepp » Tue Jan 14, 2014 12:00 am

Ok, it seems to be working now.
I suppose there was still some light coming through from the display.
When I let the circuit do its background calculations without me holding the case, and afterwards touch the case, it starts integrating.
Can't believe how sensitive it is. (even though it's shielded)
Not really usefull in this setup.

Could it be possible to use a photocell (D +-2 cm)
just to have a larger surface of junction material? And adjust the settings from 10 to .. ?
sepp
 
Posts: 8
Joined: Thu Jan 02, 2014 10:47 am

Postby thijsbeckers » Tue Jan 14, 2014 12:00 am

Well, yes, the circuit is pretty sensitive, that's what I've been trying to say .

I guess it wouldnt hurt to try a photocell. This is actually what this circuit promotes: using different 'detectors'.

We would appreciate reading about your results very much!

By the way, using multiple BPW34s in parallel also enlarges the detection surface, but due to the larger capacitance, the peak amplitude will be power...'
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

PreviousNext

Return to Test & Measurement

Who is online

Users browsing this forum: No registered users and 1 guest