USB EM84 Magic Eye - help needed

The topic on number crunching

Postby timetec » Sat Feb 06, 2010 12:00 am

Hello all - I have built the 'EM84 USB Magic Eye' CPU load monitor circuit as published in January's issue.

The tube indicator bars glow dimmly, accompanied by a slight whistle from the transformer. The HT is 216V, but the heater voltage is very low indeed.

I read that the heater supply voltage / current is PWM controlled by the PC software, and this is where my problems start.......

When the monitor is plugged into a USB port, 'Device not recognised' appears - it does not even ask for a driver. I've downloaded the AVR309.zip file from the ATMEL website and have the nessecary drivers, but don't know where to begin installing the AVR software ??


Any help would be greatly appreceiated

Many thanks, Richard
timetec
 
Posts: 4
Joined: Thu Jan 02, 2014 10:37 am

Postby phonoplug1 » Sun Feb 07, 2010 12:00 am

Just a thought, if the USB D+ and D- lines are swapped you would get that message on the PC. Worth checking?

Anything else on the USB lines (shorts etc) would probably also cause that message.
phonoplug1
 
Posts: 44
Joined: Thu Jan 02, 2014 10:37 am

Postby timetec » Sun Feb 07, 2010 12:00 am

Many thanks for the reply - all sorted now

Stupid mistake - misprogramed the fuses on the ATTINY.

Now needs a bit of tweaking, as I wound the transformer on a non-spec' former - HT now nearly 300V ! - so it will all have come to bits again.

Picture attached shows running at 20% - a bit out of sorts.

DOS Command line : cpushow 20


Richard'
Attachments
ELEKTOR.3.jpg
timetec
 
Posts: 4
Joined: Thu Jan 02, 2014 10:37 am

Postby phonoplug1 » Sun Feb 07, 2010 12:00 am

Nice work. Have to say I looked at that project with interest. Might build it now!
phonoplug1
 
Posts: 44
Joined: Thu Jan 02, 2014 10:37 am

Postby phonoplug1 » Wed Mar 03, 2010 12:00 am

Just built this with a moving coil meter, very useful. At least now I can see the computer is 'doing something' when it seems to be 'doing nothing'!

I wonder though, is there a way to run the PC application without having a window sitting on the task bar? I tend to have many things running at the same time, so the less items on the task bar the better. Any ideas??
phonoplug1
 
Posts: 44
Joined: Thu Jan 02, 2014 10:37 am

Postby godfrey » Wed Sep 08, 2010 12:00 am

Hi,

I've build this progect but unformunately it did not work. My problem is that I do not know the fuse settings. I've set CKSEL = 1111 SUT = 11 and BODLEVEL 110. However I do not know the setting for the others eg CKOUT CKDIV8 etc

Thanks in anticipation
godfrey
 
Posts: 3
Joined: Thu Jan 02, 2014 10:40 am

Postby phonoplug1 » Thu Sep 09, 2010 12:00 am

Hi Godfrey,

I recall having the same problem actually. I tried various combinations until it worked! The attachment shows the settings in my programmer's software - hopefully thats easy to translate to your programmer's.
Attachments
ProgFuses.JPG
phonoplug1
 
Posts: 44
Joined: Thu Jan 02, 2014 10:37 am

Postby godfrey » Tue Sep 14, 2010 12:00 am

Hi phoneplug1,

With the settings you gave me I was able to program the Attiny2313 and everything worked fine.

Do you by any chance know from where I can get a AVR309 Windows driiver for Windows 7/Vista

Thanks a lot!

Godfrey
godfrey
 
Posts: 3
Joined: Thu Jan 02, 2014 10:40 am

Postby phonoplug1 » Tue Sep 14, 2010 12:00 am

Is this what you're looking for?

http://www.elektor.com/magazines/2010/january/usb-magic-eye.1191254.lynkx?tab=4
phonoplug1
 
Posts: 44
Joined: Thu Jan 02, 2014 10:37 am

Postby godfrey » Wed Sep 15, 2010 12:00 am

No, I need a similar driver but for Windows 7/ Vista. The link is a driver is for the Windows XP.

Thanks
Godfrey
godfrey
 
Posts: 3
Joined: Thu Jan 02, 2014 10:40 am

Next

Return to Microcontrollers & Embedded

Who is online

Users browsing this forum: No registered users and 1 guest

cron