Pchannel FET circuit trouble

Title basically says it all

Postby felixcollins » Mon Jan 31, 2011 12:00 am

Hi,
I have a circuit that is designed to turn on an LED when a battery is removed. When signal is connected to 4v, Vgs is approx 0V so fet is off. When signal is NC, 10MOhm pulls Gate to ground, Vgs is -4V and fet turns on. Led is between Drain and ground.

  signal(4v or NC)             power (4v)          |                            |          |                      S     |          |             pfet --------           ----------------{          |              G   ----- >|-----     10 MOhm                D      led    |          |                              |          |                           30 Ohm               |                              |----------------------------------------ground (0v)


Please excuse the ASCII art. The problem I have is that the fet stays on regardless of the state of signal (gate). The fet in question is an IRLML6402TR.

Any ideas what I'm doing wrong?

Cheers,
Felix
felixcollins
 
Posts: 2
Joined: Thu Jan 02, 2014 10:40 am

Postby anneo » Tue Feb 01, 2011 12:00 am

Circuit looks ok.
Short g to s ,LED goes off : batt. too low.
LED doesn't go off :fet mouted the wrong way (s and d inverted) or dead
Also some solder in the wrong place not inpossible
Anne
anneo
 
Posts: 1339
Joined: Thu Jan 02, 2014 10:36 am

Postby felixcollins » Mon Feb 07, 2011 12:00 am

Turns out I had the leads plugged into the benchtop power supply around the wrong way! Arrrgh! Obviously the LED was hooked up wrong too. LOL.
felixcollins
 
Posts: 2
Joined: Thu Jan 02, 2014 10:40 am


Return to Home, Garden, Games, Hobby

Who is online

Users browsing this forum: No registered users and 1 guest

cron