Nouvelles versions

Ce forum est associé au livre de Stefan Schwark paru en août 2012

Nouvelles versions

Postby DavidVB » Fri Dec 02, 2016 3:08 pm

Bonjour,

Je me lance dans l'étude d'Android avec ce livre.

Problème: je n'arrive déjà pas à lancer le premier exemple (Hello World) : La mcahine AVD que je lance n'en finit pas de "démarrer" avec juste un logo Android, jusqu'à ce que je termine manuellement.

[2016-12-02 15:37:38 - HelloWorld] ------------------------------
[2016-12-02 15:37:38 - HelloWorld] Android Launch!
[2016-12-02 15:37:38 - HelloWorld] adb is running normally.
[2016-12-02 15:37:38 - HelloWorld] Performing com.androidexample.helloworld.MainActivity activity launch
[2016-12-02 15:37:38 - HelloWorld] Automatic Target Mode: Preferred AVD 'MonTerminal' is not available. Launching new emulator.
[2016-12-02 15:37:38 - HelloWorld] Launching a new emulator with Virtual Device 'MonTerminal'
[2016-12-02 15:37:46 - Emulator] emulator: WARNING: Classic qemu does not support SMP. The hw.cpu.ncore option from your config file is ignored.
[2016-12-02 15:37:47 - Emulator] emulator: Listening for console connections on port: 5554
[2016-12-02 15:37:47 - Emulator] emulator: Serial number of this emulator (for ADB): emulator-5554
[2016-12-02 15:37:47 - HelloWorld] New emulator found: emulator-5554
[2016-12-02 15:37:47 - HelloWorld] Waiting for HOME ('android.process.acore') to be launched...
[2016-12-02 15:50:43 - HelloWorld] emulator-5554 disconnected! Cancelling 'com.androidexample.helloworld.MainActivity activity launch'!

J'ai essayé avec 2 AVD différents, un sous API 8 et un sous API 15, mais sans succès.

Aurais-je un soucis avec mon installation ?
Je précise que je suis totalement novice en Android, ainsi que dans Eclipse.

Merci pour votre aide.
DavidVB
 
Posts: 3
Joined: Fri Dec 02, 2016 3:04 pm

Re: Nouvelles versions

Postby DavidVB » Sun Dec 04, 2016 4:27 pm

J'ai poursuivi mes recherches, et j'ai trouvé qu'il fallait que je modifie un paramètre dans le BIOS de mon PC pour autoriser la virtualisation.

J'ai fait cela, mais en définitive, j'en reste au même point: l'appli se build sans erreur (juste un warning car je n'utilise pas la dernière version de l' API cible), et le terminal émulé reste juste afficher le logo Android (texte "scintillant")
Donc, problème non résolu.

J'ai ensuite essayé en installant et utilisant Android Studio (sans passer par Eclipse), et là, j'arrive bien à lancer l'émulateur, mais je me retrouve avec un écran, quelques applis, mais je n'y retrouve pas mon "HelloWorld".

Toute aide serait fort appréciée....
DavidVB
 
Posts: 3
Joined: Fri Dec 02, 2016 3:04 pm


Return to Android - apprendre à programmer des applis

Who is online

Users browsing this forum: No registered users and 1 guest

cron