Nieuwe zImage op sd card, boot error

Met het Elektor Embedded-Linux-board

Postby arie86 » Sat Dec 01, 2012 12:00 am

Na een nieuwe zImage te hebben gebouwd en deze op de sd card te hebben gekopieerd start linux niet meer op.

ik krijg de volgende fout melding:

# copy ext2://1/zImage 0x30008000
1726476 bytes transferred
# boot
ARCH_ID: 9998 (0x270e)
ATAG_HEADER
ATAG_MEM: start 0x30000000 size 0x00800000
ATAG_CMDLINE: (55 bytes) 'console=ttyS0,115200n8 root=/dev/mmcblk0p1 rw rootwait'
ATAG_END
Booting kernel at 0x30008000...
Uncompressing Linux...

uncompression error

-- System halted


weet iemand wat er fout kan gaan?
arie86
 
Posts: 2
Joined: Thu Jan 02, 2014 3:41 pm

Postby cas55 » Sat Dec 01, 2012 12:00 am

Zo aan de foutmelding te zien lijkt je configuratie niet instaat de file uit te pakken. Heb je de oorspronkelijke .config file nog?

Je zou eerst kunnen proberen die te gebruiken en kijken of je zonder eigen aanpassingen in het configuratie menu een werkende zImage kan maken.

Ik heb een paar keer dit proces doorlopen en het werkt best wel mits je niet teveel extra's kiest. Ik heb de laatste keer veel moeite gedaan alle keuzes weer terug te draaien om zo weer in een stabiele situatie te komen.

Ik geef je mijn laatste .config file die in ieder geval stabiel is. Je zou eventueel ook kunnen experimenteren door andere stabiele configuratie files te proberen. Kan je aangeven welke handelingen je volgt? Uit Elektor of via GNUblin?

Ik zelf werk steeds vaker vanuit http://wiki.gnublin.org/index.php/Kernel_kompilieren_%2B_Module_installieren

Probeer iets meer aan te geven van wat je doet in welke volgorde enz.
Attachments

[The extension config has been deactivated and can no longer be displayed.]

[The extension config-gnublin has been deactivated and can no longer be displayed.]

cas55
 
Posts: 59
Joined: Thu Jan 02, 2014 3:41 pm

Postby arie86 » Sat Dec 01, 2012 12:00 am

Ik heb de instructies gevolgd die in het tijdschrift staan. Ik probeer namelijk mijn USB/LAN adpter aan de praat te krijgen(ASIX AX88772B).

Dus ik heb volgende instructies gevolgd:
(vanuit ElektorLinuxBoard/linux-2.6.33-lpc313x/ map)
- . ./set.sh

- make menuconfig (devices toegevoegd)

- make zImage

- en dan kopiëren naar sd card:
sudo cp arch/arm/boot/zImage /media/SDcard

Hierna board opnieuw opgestart en kreeg ik de melding.

Bedankt voor je reactie, ik zal is wat gaan proberen met de conf files van jou. Bedankt
arie86
 
Posts: 2
Joined: Thu Jan 02, 2014 3:41 pm

Postby 300466 » Sat Dec 01, 2012 12:00 am

Misschien helpt het volgende:

Volgens mij staat er in de tekst voor het script set.sh in het septembernummer blz 65 een fout in de regel die begint met P2=/.. Dat moet zijn: P2=/opt/eldk-5.0/armv5te/sysroots/i686-oesdk-linux/usr/bin
Zonder deze wijziging kon ik de kernel niet foutloos hercompilen.
300466
 
Posts: 5
Joined: Thu Jan 02, 2014 3:41 pm


Return to Aan de slag met Embedded Linux

Who is online

Users browsing this forum: No registered users and 1 guest