Bus Collision During a Start Condition in PIC24FJ64GA004

Discussies en opmerkingen over het Explorer-16 project

Postby m.j.mulders » Mon Jul 02, 2007 12:00 am

Deze PIC is een iets kleinere uitvoering (28 pins DIL) van de in het EXPLORER16 project gebruikte PIC24FJ128GA010. Voor eigen ontwikkeling geef ik de voorkeur aan 0,1-inch boven inzet van de geboden PIM’s en schrijf in assembler.
Het probleem is nu dat elke “I2C-START” (bset I2CxCON,#SEN) direct een bus-collision tot gevolg heeft (BCL-bit in I2CxSTAT), terwijl er géén andere MASTER is.
Ook wanneer de SCL en SDA pinnen alleen zijn verbonden met een weerstand aan de +3,3 volt treedt dit probleem op. De waarden van deze pull-up weerstanden heb ik gevarieerd tussen 1K (mag minimaal 439ohm zijn volgen Microchip) en 10K (een prima waarde bij de diverse andere PIC’s die ik gebruik).
Het lijkt erop dat de PIC heel even een “0’ leest op de SDA-lijn, terwijl hij een “1” verwacht .
In de diverse forums van Microchip wordt dit probleem frequent genoemd voor diverse 16-bitters, maar nergens kan ik een sluitende oplossing vinden.
Ook het plaatsen van een C’tje (ca 50pF) aan de pennen gaf bij mij geen resultaat.
Het probleem treed zowel bij de default I2C-pennen als de alternate pennen op.
Ook geen verschil bij gebruik I2C1 of I2C2, aan/uitzetten “SMEN” (SMBus levels) en variaties in de BRG-waarde (Clock Rates).
Heeft iemand ervaring met dit probleem??
m.j.mulders
 
Posts: 1
Joined: Thu Jan 02, 2014 3:43 pm

Return to 2007-01 t/m 04 Explorer-16

Who is online

Users browsing this forum: No registered users and 1 guest