Combi C-meter (ander probleem ?)

FAQ en discussie

Postby martinsmallegoor » Thu May 31, 2007 12:00 am

Hier hetzelfde probleem met de Combi-C meter.
Alleen capaciteitsmeting werkt, omschakeling naar ESR doet niets...
Vervolgens n.a.v. tips alhier maar het C'tje van 22pF tussen de beide PIC's gezet ipv naar ground.
En voila! , er is ESR beeld op het display .

Maar na het testen met diverse elcos bleek de waarde helemaal verkeerd. Veel waardes lagen rond de 80-90 ohm, terwijl <1 vrij normaal hoort te zijn.

Geheugenscoop erbij, het blijkt dat de signalen op pen 1 en 18 van PIC16F84 niet stabiel zijn. Deze zijn aanwezig met verschillende duty cycles. Ik heb hier scoopplaatjes van, maar ja die kan ik hier niet bijvoegen. Dus verder zoeken in de oscillatie hoek.

Na een tip van ik meen Zwabber heb ik de 22pF naar Gnd weer teruggezet en een 12pF in serie naar pen 16 (uit het voetje) geplaatst.

Tada !!!!!!!!
Het werkt, de blokgolven op pen 1 en 18 zijn stabiel. De ESR ligt tussen de 0 en 1 ohm.
Nog even calibreren met referentiemateriaal (handig, werken bij een electronica bedrijf ) en klaar is Martin...

Ik hoop dat jullie ook wat aan deze info hebben.
martinsmallegoor
 
Posts: 1
Joined: Thu Jan 02, 2014 3:43 pm

Postby zwabber » Thu May 31, 2007 12:00 am

Geplaatst door:StafVG op 9-10-2005 15:32:15
Ik meet echter een ESR van 1 en een weerstand van 80. Een gelijkaardige, volgens mij goede condensator meet een ESR van 0,8 en een gelijkstroomweerstand van 78.


Ik zou de meter toch testen met nieuwe condensatoren, alles voor de zekerheid! Zo is het bij mij ook gebeurd, en een DC weerstand heb ik nooit gemeten. ESR lag tussen 0 en 1 Ohm, DC weerstand stonden streepjes... Als je een DC weerstand meet is de condensator rijp voor de vuilnisbak denk ik. Een voeding afvlakken met zo'n condensator lukt toch niet? Je belast ze dan (op DC) met 80 Ohm.

Waar je wel op moet letten: Als één van de 4 draadjes naar de probes afbreekt, krijg je rare toestanden. Zo krijg je onrealistische meetwaarden... (bvb ESR 50 Ohm, DC 80 Ohm) Ook moet je bij opzetten van de meter in ESR modus, de probes kortsluiten. (Als alles goed zit, maar de probes zijn niet kortgesloten, wordt dat zelfs gevraagd.) Als er toevallig nog een condensator, of weerstand tussen zit, krijg je verkeerde instellingen en zijn de aflezingen ook niet goed.

Zwabber

zwabber
 
Posts: 2
Joined: Thu Jan 02, 2014 3:43 pm

Postby Guest » Thu May 31, 2007 12:00 am

Hallo allemaal,

Ten eerste mijn excuses voor het langer uitblijven van een reactie van onze kant. Aangezien er veel vragen blijken te zijn over de ESR/C-meter leek het ons verstandig om eerst eens te kijken naar wat er allemaal zo hier en daar misgaat en uit te zoeken waat het fout is gegaan.

Er zal binnen afzienbare tijd een FAQ komen over dit onderwerp, maar de meest belangrijke antwoorden kan ik hier ook alvast kwijt. Zie dit als een voorproefje op de FAQ.

Veel mensen blijken problemen te hebben met het LCD. Dit wordt veroorzaakt doordat bij veel mensen het LCD verkeerd wordt aangesloten. Het LCD dat door ons geleverd wordt is voorzien van 16 pennen, waarvan de rechtse 2 worden gebruikt voor de aansturing van de achtergrondverlichting. Op de module is te herkennen dat de linkse pen pen nr. 14 is en de 3e pen van rechts pen nr. 1. Deze aansluitingen (1 tm/14) moeten d.m.v. de bandkabel en de bijbehorende plug en connector verbonden worden met pen 1 t/m 14 op de printplaat. De aansluitingen 15 en 16 op de printplaat worden dus nergens mee verbonden, net zoals de aansluitingen A en K (ook te herkennen op de LCD-module) niet worden aangesloten.

Een 2e oorzaak van de problemen is te wijten aan het feit dat wij enkele controllers geleverd hebben waarvan de oscillator dusdanig is ingesteld, dat deze niet goed overweg kan met de hoge kloksnelheid die in onze schakeling gebruikt wordt. Het betreft hier een aantal controllers PIC16F84. In het geval dat deze controller alleen werkt i.c.m. de truuk met een 22pF-capaciteitje, is deze verkeerd geprogrammeerd. Verkeerd geprogrammeerde controllers kunnen naar Elektuur worden gestuurd waarna deze juist opnieuw geprogrammeerd worden.

Ik hoop dat bovenstaande oplossingen voor de problemen in ieder geval het grootste gedeelte van de problemen kan oplossen. Zoals gezegd zal er spoedig een FAQ komen, want wij willen uiteraard alleen tevreden klanten hebben. Ook wij zijn elektronica-enthousiastelingen en weten hoe vervelend het kan zijn als iets niet (goed) werkt..... Niets menselijks is ons vreemd

Nogmaals hartelijk dank voor jullie getoonde geduld. En veel succes (en plezier) met jullie ESR/C-meter.

Groeten,
Paul Goossens
Guest
 

Postby Guest » Thu May 31, 2007 12:00 am

Dank voor het eindelijk reageren! Twee vragen blijven open:

-Kun je aan het typenummer, of serienummer van de PIC84 zien of het een "verkeerde" is?

-Hoe zit het nu met de schakelaar S1, want inderdaad is het, zoals gepubliceerd, niet goed, en wat is daar trouwens de reden van?
Guest
 

Postby thijsbeckers » Thu May 31, 2007 12:00 am

Nee, je kunt het niet aan het serienummer zien. De eerste modellen zijn goed, tot er op een gegeven moment iets mis is gegaan (bestand beschadigd o.i.d.) De laatste nieuwe versies worden voorzien van een "a" en zijn wel weer goed.

Bij de voeding is de plaats van S2 het inderdaad niet echt handig gekozen. IC7 blijft continu onder spanning staan en dat is bij draagbare meetapparaten niet echt gewenst. Foutje shit wvroemen heeft het probleem ook al opgelost, maar als het goed is komt er nog een uitgebreidere FAQ.
thijsbeckers
 
Posts: 1134
Joined: Thu Jan 02, 2014 10:37 am

Postby rdebruijn » Thu May 31, 2007 12:00 am

Hallo paulgoossens,

Met het verhaal van de HS bit bent u er nog niet naar mijn mening.
Als jullie de controllers hebben geprogrammeerd met de software die wij als lezers kunnen downloaden van u site, zal de meter niet goed werken.
Met namen de ESR meting, dit komt omdat u bij de compiler van firma Oshon (die is gebruikt) een verkeerde clock frequentie heeft ingevoerd.
Daarvoor is een te lage clock frequentie gekozen, daardoor worden de wait instructies in het programma te kort.
Waardoor de programma’s in de controllers te snel lopen.
Dit merk je met namen bij de buzzer, deze geeft korte en hoge piepjes.
En het signaal op de pennen 1 en 18 van de pic16f84 is geen 100KHz maar 161KHz.
Dit komt omdat de compiler de wait instructies aanpast aan de waarde van de kristal frequentie, die is ingevoerd.

En zo als ik al eerde heb gemeld op het form is het programma slordig geprogrammeerd.
Zo is het onjuist gebruik van gosub instructies, het onnodig vaak wissen van het lcd-scherm waardoor het knippert.
Er zitten twee subroutines in met de naam delay.
De 1e is: delay:
delaycount = 0
While delaycount <= 1 ' delay For trig pulse
delaycount = delaycount + 1
Wend
Return
En de 2e is: delay:
WaitUs 2
Return
Mijn vraag is aan u welke is nou de juiste subroutine?
Want daar ben ik nog niet uit.

Groeten, Ronald

PS: het is jammer dat ik niet het programma van mij op u site kan zetten.
Want naar mijn mening werkt dat een stuk beter.

rdebruijn
 
Posts: 7
Joined: Thu Jan 02, 2014 3:37 pm

Postby Guest » Thu May 31, 2007 12:00 am

Hallo,

Kunt u uw programma misschien naar ons e-mailen? Ik zal dan deze nieuwe software testen. Als U akkoord gaat, wil ik deze nieuwe software op de site zetten zodat anderen hier ook gebruik van kunnen maken.

Het kan wel een week duren eer ik weer reageer, aangezien we redelijk druk zijn op dit moment. Ook gaan we tussendoor nog naar de HCC, dus echt veel tijd heb ik de komende week niet.

Ik ben benieuwd naar uw software,

Groeten,
Paul Goossens
Guest
 

Postby Guest » Thu May 31, 2007 12:00 am

Dag Ronald,
ik heb de Combi_Cmeter inmiddels bijna aan de praat.
Maar dat heeft wel een hoop moeite gekost. shit Programma idd verkeerd gecompileerd, en heel slordig geschreven.
Waar ik nog niet uit ben is hoe ik de timing van de diverse routines moet aanpassen, zodat er piepjes uit de buzzer komen en de frequentiegenerator idd 100 KHz produceert, ipv 161. En het beeld is nog een beetje nerveus, dus ik moet ook die clearscreen eruit halen.
Zou je mij jouw programma willen sturen? Ik zie het tenminste niet op de site verschijnen.
Bij voorbaat dank en met vriendelijke groet,
Jelle Aarnoudse
aarno009@planet.nl
Guest
 

Postby xbake » Thu Jul 24, 2008 12:00 am

hallo ronald,

ik heb je gemaild, maar vergat er mijn mailadres bij te zetten.
Bij deze:

bert punt de punt baecke at telenet punt be

mvg, bert
xbake
 
Posts: 42
Joined: Thu Jan 02, 2014 3:31 pm

Previous

Return to 2005-09 Combi-C-meter

Who is online

Users browsing this forum: No registered users and 1 guest

cron