Het Elektor forum gaat sluiten. Zie ook deze link. Vanaf vrijdag 15 maart is het niet langer mogelijk om in te loggen op het forum. Wel blijft de inhoud van het forum nog zichtbaar tot het einde van de maand maart. Per 1 april gaat het forum definitief uit de lucht.

Directe aansturing MOSFET door microcontroller

Ontwerpen en programmeren

Postby jan.lichtenbelt » Mon Dec 12, 2011 12:00 am

Beste Piet,

Bedankt voor de programma's. Dat is heel eenvoudig!
Maar wel een andere toepassing dan waar ik aan denk, nl een motor besturing. Daarvoor is wel aangepaste programmatuur nodig.

Groetjes

Jan
jan.lichtenbelt
 
Posts: 195
Joined: Thu Jan 02, 2014 3:28 pm

Postby anneo » Mon Dec 12, 2011 12:00 am

De diodes zitten wel goed,langsdaar moeten de poorten van de P-mos dichtgedrukt worden (naar + getrokken)
De oplossing met één ingang geeft een stilstaande motor bij 50% PWM als de schakeling mooi symetrisch werkt.Bij draaien staat de spanning om en om op de motor,nooit zonder,lijkt me niet voordelig.
Met twee ingangen staat ie stil zonder pulsen,lijkt me wel zo rustig.
Vermoedelijk is de schakeling met 1 in alleen bedoeld voor vol rechts of vol links en spaning eraf om te stoppen,niks regelen.
Anne
anneo
 
Posts: 1339
Joined: Thu Jan 02, 2014 10:36 am

Postby jan.lichtenbelt » Mon Dec 12, 2011 12:00 am

Beste Anne,

Toch wordt in kant en klare IC's wel degelijk van een PWM en een geïnverteerde PWM gebruik gemaakt.

We behoeven hier het wiel niet opnieuw uit te vinden. Kijk eens op de zeer mooie sitehttp://modularcircuits.tantosonline.com/blog en klik op articles.

Groetjes

Jan Lichtenbelt
jan.lichtenbelt
 
Posts: 195
Joined: Thu Jan 02, 2014 3:28 pm

Postby anneo » Mon Dec 12, 2011 12:00 am

Da's idd mooi uitgelegd daar.
Als je kijkt bij Lock Anti-Phase Drive dan is dat met één stuursignaal.Het klopt dus volgens hun wat ik zei,bij 50% PWM staat de motor stil.Bij andere instellingen loopt er stroom in twee richtingen.Zij voorkomen dat de voeding voor alles moet opdraaien door een flink dikke C over het geheel te zetten.Moet wel er wel een zijn die een fikse stroom kan hebben.
Anne
anneo
 
Posts: 1339
Joined: Thu Jan 02, 2014 10:36 am

Postby jan.lichtenbelt » Sun Jul 15, 2012 12:00 am

Beste mensen,

Het is al weer even geleden, maar ik ben steeds met de software bezig geweest. Nu weer de hardware. Er gebeuren rare dingen. Hierbij het schema. Op plaats I zet ik een PWM (periode tijd 35 usec, onderste pulsen op de plaatjes) en de andere aansturing van deze brug staat continue laag (plaats VI op 0V). Op de Gate van Q1 (plaats II) staat een spanning die binnen 3usec op 4 volt zit, zie plaatje II_t. Echter op de 12V voeding, zowel een labvoeding als, 12 NiMH accus'(3Ah) komt een ribbel, zie plaatje III_t. Alle Grote MOSFET's worden warm, evenals de 7805. De (gemiddelde) stroom is maar 60 mA. Tenslotte nog iets merkwaardigs. de spanning over de shunt wordt -0.5Volt, zie plaatje V_t, hieronder.
Wat gaat er fout en waarom?

groetjes

Jan Lichtenbelt

Plaatjes:
1. Schema
2. punt II in het schema (bovenste helft met 0V in het midden)
3. punt III in het schema bovenste helft met 0V in het midden)
Onderste helft is punt I in het schema
Attachments
RemoteControl-V11.jpg
II-t.jpg
III-t.jpg
jan.lichtenbelt
 
Posts: 195
Joined: Thu Jan 02, 2014 3:28 pm

Postby jan.lichtenbelt » Sun Jul 15, 2012 12:00 am

Zie hierboven
Plaatje is punt V in het schema (bovenste helft en onderste helft is punt I)
Attachments
V-t.jpg
jan.lichtenbelt
 
Posts: 195
Joined: Thu Jan 02, 2014 3:28 pm

Postby jippie » Mon Jul 16, 2012 12:00 am

@Jan: Wil je bij de plaatjes even kort een titeltje zetten? Ik raak de draad een beetje kwijt met welk signaal er in welk plaatje staat.
jippie
 
Posts: 342
Joined: Thu Jan 02, 2014 3:28 pm

Postby anneo » Mon Jul 16, 2012 12:00 am

'tJa dat zit niet helemaal snor zo te zien.
Eerst even wat foutjes,heeft er verder niks mee te maken,maar dan is dat alvast uit de weg.De zener bij de stroomvoeling zit omgekeerd en de PIC heeft geen massa-aansluiting.
Nu ter zake,er ontbreekt een dikke C over de Fet-schakeling.De snelle pulsen veroorzaken last met parasitaire capaciteiten en zelfinduktiesOok de stroomvoel-weerstand heeft daar blijkbaar nogal wat last van.
Hoge schakelsnelheden vragen veel stroom om de fet's aan te sturen,drivers kunnen 1 tot 2A piek leveren,lukt de PIC nooit.Zo blijft de fet te lang tussen geleiden en afgeschakeld hangen.Je moet hier eerder in ms dan in µs denken,minder vaak schakelen.
Dat de 7805 warm wordt bij 60mA,misschien een beetje bij (12-5)x60=420mW.Kan ook dat ie warmer wordt door oscillatie,moet meestal dicht bij de IC van 100nF ontkoppeling voorzien zijn.Vooral tussen in en massa.
anneo
 
Posts: 1339
Joined: Thu Jan 02, 2014 10:36 am

Postby jippie » Mon Jul 16, 2012 12:00 am

AnneoEerst even wat foutjes,heeft er verder niks mee te maken,maar dan is dat alvast uit de weg.De zener bij de stroomvoeling zit omgekeerd en de PIC heeft geen massa-aansluiting.

De elco achter de 7805 zit ook ondersteboven.

AnneoDat de 7805 warm wordt bij 60mA,misschien een beetje bij (12-5)x60=420mW.Kan ook dat ie warmer wordt door oscillatie,moet meestal dicht bij de IC van 100nF ontkoppeling voorzien zijn.Vooral tussen in en massa.

Wat voor stroommeter gebruik je Jan? Bij zulke frequenties èn niet-sinusvormige spanningen kan de werkelijke stroom er flink naast zitten.
jippie
 
Posts: 342
Joined: Thu Jan 02, 2014 3:28 pm

Postby eriksl » Tue Jul 17, 2012 12:00 am

Even iets wat een kleine beetje gerelateerd is... Ik heb hier nu een paar attiny's liggen en ik wil daarmee mosfets gaan aansturen (net als Jan). Ik heb twee smaken mosfets liggen, irfz44 en irl2703. Als ik naar de datasheets kijk, lijkt het er op dat de irfz44 niet geschikt is en de irl2703 wel, klopt dat? Ik vind de "nomenclatuur" van mosfets in de datasheets nog erg moeilijk :-/
eriksl
 
Posts: 515
Joined: Thu Jan 02, 2014 3:28 pm

PreviousNext

Return to Microcontrollers

Who is online

Users browsing this forum: No registered users and 1 guest