50 PIC Microcontroller projecten

Ontwerpen en programmeren

Postby jeroen1960 » Tue Jul 05, 2011 12:00 am

Hey Henny,

Helaas vanmiddag geen tijd gehad om naar mijn breadbord te kijken. Ik heb wel even naar jouw foto gekeken. Het enige dat ik niet begrijp is wat het doel is van het rode draadje rechts onderin en links van de led die je gebruikt om de spanning te controleren. Het zou +5v moeten verbinden ergens mee maar ik zie er niets omheen zitten. Voor de rest is de foto mij duidelijk.

Groet,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby arjen h. » Tue Jul 05, 2011 12:00 am

Dat rode draadje doet niets, is waarschijnlijk blijven zitten van de vorige opstelling.
Het Elektor forum is voor de lezers; voor een vraag aan de redactie kun je het beste Elektor een email sturen.
arjen h.
Moderator
 
Posts: 1317
Joined: Thu Jan 02, 2014 10:40 am

Postby jeroen1960 » Tue Jul 05, 2011 12:00 am

Haha....dat dacht ik wel...maar de amateur die ik ben ging er vanuit dat die nog wel een functie zou hebben.

Groet,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby jeroen1960 » Wed Jul 06, 2011 12:00 am

Hey Henny,

H.BeekmanTen tweede: aan de zijde van de 15 polige Sub-D connector zit een driepolige pin header. Afhankelijk van de gebruikte PIC moet deze in in Dis(abled) of Ena(bled) staan. Voor de 16F877A moet deze in Dis(abled) staan.


Toch nog even snel je reactie doorgelezen. Ik heb nu de 3-polige header gevonden. Er staat ena / dis bij en het jumpertje stond aan te schurken tegen de ena stand ( dat is tegen de weerstanden aan ). Ik heb de jumper verplaatst naar dis.

H.BeekmanAls je de Wisp voed via de +/0 of via de DC-plug hoef je breadbord niet te voeden, dit gebeurt al via de rode en zwarte draad van de Wisp.

Hoe moet de wisp648 gevoed worden ? Is daar een soort trafo voor nodig die 9-18V DC levert ??
Ik dacht dat ik hem kon doorlussen via de usb kabel naar een pc om zo de benodigde stroom te krijgen anders moet ik nog even een trafo kopen.

H.BeekmanTen eerste: heb je de losse adaptor van minimaal 8 volt aangesloten op de Wisp 648, een te lage spanning laat de 7805 niet goed werken en dan heb je geen +5 Volt en dan doet deze het niet(goed).

Ik begrijp niet helemaal wat je bedoelt met losse adaptor van min. 8V. Bedoel je daar de aansluiting mee van de usb aansluiting via usb kabel naar de pc ??

Groet,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby h.beekman » Wed Jul 06, 2011 12:00 am

Aan de zijde van de RS232 verbinding (9-polige Sub-D).
(gezien van af de connectorzijde)
Zit links een klemmen strook (blauw) met + en 0.
Rechts zit een DC chassisdeel rond met pin.
Hierop kun je of een adaptor met een spanning tussen de 8 en 18= Volt op aansluiten of eventueel een losse voeding met ongveer die spanning.

Zelf vind ik een adaptor handiger.
Maar de keus is aan jou.

Als je bij Voti de bouwaansluiting download vind daar ook een goede toelichting.

Henny
h.beekman
 
Posts: 74
Joined: Thu Jan 02, 2014 3:27 pm

Postby msilvius » Wed Jul 06, 2011 12:00 am

De adaptor is wat jij een "trafo met 9 - 18V DC" noemt.

Vaak kun je die dingen instellen.
Let er dan op dat je de goede spanning kiest.
msilvius
 
Posts: 701
Joined: Thu Jan 02, 2014 3:27 pm

Postby jeroen1960 » Thu Jul 07, 2011 12:00 am

MSilviusDe adaptor is wat jij een "trafo met 9 - 18V DC" noemt.

Vaak kun je die dingen instellen.
Let er dan op dat je de goede spanning kiest.


Net een nieuwe adaptor gekocht. Gisterenavond nog even geprobeerd om stroom op het breadbord te krijgen maar het lampje van de adaptor bleef alleen maar uit. De nieuwe adaptor kan max 12V leveren en dat was meer dan genoeg. Qua stroom zat het ook goed. Vanavond ga ik het nog eens proberen.

Groet,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby jeroen1960 » Fri Jul 08, 2011 12:00 am

Forum,

Oke, alles gedownload van de Voti website van het boek "PIC Microcontrollers van Bert van Dam 2007". Dat had ik al een paar weken geleden gedaan.
Nog een 22uF stabilisator condensator erbij gekocht en nog 3 ontkoppelcondensatoren van 0.1uF zoals beschreven staat op blz 11 van het boek. De ontkoppelcondensatoren zijn erg groot maar volgens de man in de elektronica zaak trekken ze gewoon wat meer stroom. Daarom zijn ze wat groter.

Ik heb spanning op de randen van het steekbord en als ik de adaptor ( met 9V ) aanzet dan gaat het led op de hoek ook branden. Die behoort volgens de schrijver niet te gaan branden dus ik keer hem om. Maar goed : het bewijs is geleverd dat de spanning door het steekbord heen gaat. Dat ledje fungeert als beperkte beveiligingsdiode. Het schema zou nu dus goed moeten zijn.

De whisp648 levert echter nog wat hoofdpijn op. Ik heb de DB15 connector zoals aangegeven in de manual van de whisp648 verbonden met het breadbord. Via de DB9 connector heb ik de bijgeleverde 9-pins naar usb aangesloten op de pc. Windows XP herkent de aansluiting echter niet. De manual van de whisp648 geeft ook geen uitsluitsel hierover alleen dat aansluiting moet plaatsvinden via seriele poort. Ik heb een kabel om van serieel naar usb te gaan dus lijkt het mij verstandig om die te gebruiken.
Als ik het eenvoudige aan/uit led programma met de JAL edit software ga compileren gaat dit goed. Het sturen naar de PIC lukt echter niet. De foutmelding in XP is dat er geen communicatie kan worden opgezet. De manual geeft het volgende aan :
"The Wisp648 has an on-board 7805-based power supply. To use this supply you must connect an external wall-wart that supplies 9 .. 18V DC."

De 12V DC die ik via de adaptor doorgeef zou voldoende moeten zijn.


Ik heb 2 vragen :
1. is er een driver voor de 9 pins aansluiting van de whisp648 naar de usb aansluiting op de pc of moet het gewoon standaard werken ??
2. kunnen er nog andere redenen zijn dat de communicatie niet tot stand gebracht kan worden ( whisp648 gewoon stuk bv ) ??
3. is er nog een manier om de whisp648 uit te testen op correcte werking ?

Bedankt,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby jeroen1960 » Fri Jul 08, 2011 12:00 am

Forum,

De 2 vragen zijn uiteindelijk 3 vragen geworden maar na nog wat zoeken in het doosje van Voti vond ik een kabel die van serieel naar serieel gaat. Nu krijg ik wel een communicatie van pc naar steekbord met de jal software. De ledjes gaan nu ook branden...

Volgens een ander forum zou er nog een xp driver op cd bijgeleverd moeten zijn maar die is men bij Voti waarschijnlijk vergeten. Ik kan hem jammer genoeg niet vinden op internet. Jammer.....misschien zo onder linux nog even proberen...

Samenvattend Het "Eureka" gevoel begint te komen....

Bedankt tot zover,

Jeroen
jeroen1960
 
Posts: 24
Joined: Thu Jan 02, 2014 3:35 pm

Postby h.beekman » Sun Jul 10, 2011 12:00 am

Hallo Jeroen,

Even een kort berichtje.
De adaptor (8-18V) sluit je aan op de Wisp648
Deze maakt er netjes 5 Volt van.
Dit kun je meten op de zwarte en rode draad van de Wisp648.

De Wisp648 voedt dus het breadbord met een spanning van 5 Volt.

Een PIC mag beslit niet meer dan 5 Volt hebben, krijgt hij dat wel dan is het einde voorstelling.

Ik begrijp dat je ca 9 Volt op het breadbord hebt gezet en daar de Wisp648 op aangesloten.

De kans is heel groot dat de interne spanningsregelaar de LM 7805 nu kapot is. Maar de Pic in de Wisp648 (12f648) is er dan waarschijnlijk ook aan overleden.

Pas wanneer een een Pic goed werkend hebt kan je hem loskoppelen van de Wisp648. Vervolgens voedt
je het breadbord met een extrene spanning van 5 Volt. Dan werkt de Pic standalone.

Groet,
Henny
h.beekman
 
Posts: 74
Joined: Thu Jan 02, 2014 3:27 pm

PreviousNext

Return to Microcontrollers

Who is online

Users browsing this forum: No registered users and 1 guest