Updating the USB Connectivity Firmware

Fragen, Tipps & Tricks zu unserem PIC-Projekt

Postby ralf4713 » Thu May 31, 2007 12:00 am

Hallo,
nachdem mein Versuch mit dem PICkit2 das Explorerboard zu flashen
gescheitert war, habe ich mich noch einmal daran gemacht wie in der Anleitung Explorer 16 User Guide 51589a.pdf beschrieben.
Aber auch da tut sich nichts.
Ich habe den Eindruck das bei den ausgelieferten Produkten weder
die Firmware noch die dazugehörigen PC Programme passen.
Man kann nicht wissen ob ein USB update notwendig ist oder nicht
da es kein Versionsmanagement gibt.
Es ist nicht beschrieben wie welche Schalter auf dem gesetzt sein müssen. Ich kann nicht daran glauben dass das egal ist.

Dann habe ich mich über kleine Qualitätsmängel ärgern müssen.
Eine Led im Low Pin count Board funzelt nur und die Membran des Lautsprecher vom NF Board ist zerquetscht.

Irgendwie bin ich von den hochgelobten
Microchipprodukten enttäuscht
Gruß Ralf


ralf4713
 
Posts: 14
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

Hi, auch hier habe ich das seltsame Gefühl das die Zusammenstellung nicht stimmt. Meine ganz konkrete Frage:

Wie kann ich mein Program das ich im MPLAB IDE compiliert habe auf das PIC schreiben ohne dass ich PICkit2 verwenden muss.

Ich möchte nämlich später meine Programme auf die 100-Pin PICs schreiben und den Explorer 16 nutzen. Wenn das nicht mal mit den kleinen PICs funktioniert bin ich jetzt scho gefrustet...

Vielleicht machen wir was falsch?????
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby radiomann » Thu May 31, 2007 12:00 am

Bei mir hat alles sehr gut funktioniert.
Zuerst mit der CD von Elektor die Software installieren und dann das Board anschliessen, so wie beschrieben. Dann wurde ein Update gemacht und alles lief.

Gruß
Werner
radiomann
 
Posts: 74
Joined: Thu Jan 02, 2014 10:41 am

Postby joeybayless » Thu May 31, 2007 12:00 am

Hi Werner,

bei der Explorer Doku 51589 Chapter 2.6 - Programmining the Device, steht dass man unbedingt den ICD 2 Treiber installieren muß. Hast du dass getan? Wenn ja wie mache ich dass ohne ICD 2. Ich verstehe die Vorgehensweise nicht an dieser Stelle.

Danke und Gruß - Joe
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

Here is the answer I got from Microchip:

Hello Joe,
End of February , we expect MPLAB IDE Version 7.52 where the PIC16F690 will be supported with PICkit 2 ( green light )
At the following Link,
http://www.microchipdirect.com/ProductDetails.aspx?Catalog=BuyMicrochip&Category=Adapters&mid=13
you find
Part Number: AC164110 - RJ-11 to ICSP Adapter
with this adapter, you can connect your PICkit2 to the RJ11 Connector of Explorer 16 board.
The USB hardware interface implemented on the board is not yet functional.
regards
technical support.

Gruß - Joe
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

So as I say I have not yet tried to program a PIC on the Explorer board. Maybe things will be clearer after my attempt. I am still a little confused that the ICD 2 USB driver must be installed before programming the device on the Explorer 16.
Anyway the Tech Support at Microchip was quick with the answer and it explains why the low count pic cannot be programmed from the MPLAB IDE.

Hey - half the fun is trial and error
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby radiomann » Thu May 31, 2007 12:00 am

Hallo Joe
radiomann
 
Posts: 74
Joined: Thu Jan 02, 2014 10:41 am

Postby radiomann » Thu May 31, 2007 12:00 am

Hallo Joe,

den hatte ich schon vorher weil ich das hatte.

Gruß
Werner
radiomann
 
Posts: 74
Joined: Thu Jan 02, 2014 10:41 am

Postby ralf4713 » Thu May 31, 2007 12:00 am

Habe ich das jetzt richtig verstanden, dass wir
mit unseren Mitteln zur Zeit keine Chance haben
das Board zu flashen?
ralf4713
 
Posts: 14
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

Ich fürchte ja, Ralph. fairerweise hat Elektor den Hinweis nach geschoben dass das Board erst Ende Februar lieferbar sei. Haben sie wohl was geahnt? Ich habe sehr früh bestellt und schon am Donnerstag letzte Woche die Lieferung bekommen. Also geduldig warten und hoffen dass das Update pünktlich zum Ende des Monats da ist....
Aber viel wichtiger dass alles dann auch funtioniert. Noch bin ich rühig..
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Next

Return to Explorer-16

Who is online

Users browsing this forum: No registered users and 1 guest