PICKit2 crashed mit MPLAPv7.50

Fragen, Tipps & Tricks zu unserem PIC-Projekt

Postby ralf4713 » Thu May 31, 2007 12:00 am

Hallo,
irgendwie funktioniert MPLAP mit dem PICkit2 nicht immer.
Zum Anfang funktionierte das Gespann fehlerfrei aber
jetzt bleibt die Busy LED leuchten und ich kann
jetzt nur noch die PICKit2 Soft nutzen (mit dem PIC16f690). Was mache ich falsch?
Außerdem habe ich das Elektor Beispiel für den Explorer16 compiliert.
Wie bekomme ich dass auf den Chip?
Jedenfalls erkennt der PICKit2 den Explorer 16 nicht und ich kann nicht flashen.
Wo finde ich ein gettingstarted für den
Explorer 16?
Gruß Ralf
ralf4713
 
Posts: 14
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

Hallo, ich habe die gleiche Erfahrung machen müssen. Ich bin noch gar nicht zum Explorer 16 gekommen. Ich kann mein Code in IDE compilieren und als Hex Datei ablegen. Ein Schreiben von IDE auf das PICkit2 funktioniert nicht. Erst wenn ich die Hex-Datei mit PICkit2 V2.01 SW auf das PIC 16F690 schreibe funktioniert es auch. Sollte das nicht mit IDE auch funktionieren?
Ein Verify bringt Fehlermeldungen und es sieht aus als ob es mit der +5 VDD zu tun hätte. Die IDE Anleitung beschreibt die notwendige Installation des ICD 2 USB Drivers. ICD2 haben wir aber nicht. Wie geht es weiter????
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby radiomann » Thu May 31, 2007 12:00 am

Ich glaube wenn man den ICD2 oder .. nicht hat und nur den PICkit2 dann uss man das mit der PICkit2 software machen.

Gruß
Werner
radiomann
 
Posts: 74
Joined: Thu Jan 02, 2014 10:41 am

Postby joeybayless » Thu May 31, 2007 12:00 am

Here is the answer I got from Microchip:

Hello Joe,
End of February , we expect MPLAB IDE Version 7.52 where the PIC16F690 will be supported with PICkit 2 ( green light )
At the following Link,
http://www.microchipdirect.com/ProductDetails.aspx?Catalog=BuyMicrochip&Category=Adapters&mid=13
you find
Part Number: AC164110 - RJ-11 to ICSP Adapter
with this adapter, you can connect your PICkit2 to the RJ11 Connector of Explorer 16 board.
The USB hardware interface implemented on the board is not yet functional.
regards
technical support.

Gruß - Joe
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm

Postby joeybayless » Thu May 31, 2007 12:00 am

Das Einspielen des MPLABV7.52 löst die Probleme! Es gibt auch ein PICkit2 SW Update auf V2.10.
Viel Spass und Gruß
joeybayless
 
Posts: 36
Joined: Fri Jan 03, 2014 1:53 pm


Return to Explorer-16

Who is online

Users browsing this forum: No registered users and 1 guest