Nichts geht!

Tipps & Fragen zum Reader-Bau

Postby holger1 » Thu May 31, 2007 12:00 am

Nachdem der Leser und drei Karten angekommen sind, kann ich trotzdem nicht damit experimentieren.
Da Display habe ich noch nicht angelötet. Wenn ich das USB-Kabel anschließe, leuchten 2 rote LED (D3+D6), D1 und D2 ( grün und gelb) leuchten nur kurz. Im MIFARE-Magic-Terminal wird nichts angezeigt.
Wo liegt das Problem ?
holger1
 
Posts: 13
Joined: Fri Jan 03, 2014 1:50 pm

Postby obelix179 » Thu May 31, 2007 12:00 am

Hatte ich auch. der Prozessor war nocht programiert ))
es wird zwar eine geprüfte Einheit ausgeliefert, Aber das Prüfergebnis wir ja nicht mitgeteilt.
obelix179
 
Posts: 6
Joined: Fri Jan 03, 2014 2:03 pm

Postby holger1 » Thu May 31, 2007 12:00 am

Gut, dass es nicht nur mir so geht.
Aber was hast Du dann gemacht?
Firmware-Update oder ein Programm?
Und insbesondere: wie?
Gib mir doch bitte mal paar Tips!
Danke
holger1
 
Posts: 13
Joined: Fri Jan 03, 2014 1:50 pm

Postby obelix179 » Thu May 31, 2007 12:00 am

Schau Dir mal die Beschreibung hier"http://www.elektor.de/Default.aspx?tabid=28&year=2006&month=9&art=5550889"
an. Da bekommst Du alles was mann zum Softwareaufspielen braucht. Ach ja 2 Steckbrücken mußte ich noch nachlöten.
obelix179
 
Posts: 6
Joined: Fri Jan 03, 2014 2:03 pm

Postby holger1 » Thu May 31, 2007 12:00 am

Danke, Obelix, mal sehen, dass ich schnellstens dazu komme.
holger1
 
Posts: 13
Joined: Fri Jan 03, 2014 1:50 pm

Postby holger1 » Thu May 31, 2007 12:00 am

Hallo nochmal, zunächst hab ich mal das Display angeschlossen: 16 schwarze Blöcke. Die beiden Jumper hab ich eingesetzt und dann nach der Anleitung losgelegt. Beim Flash Magic hab ich aber immer wieder folgende Fehlermeldung erhalten:
"Unable to connect at the specified baudrate. Try reducing the baudrate. Reset the hardware into ISP mode again."
Ich habs dann mal mit 600 probiert, hat auch nicht geholfen.
"Reset auf ISP mode" sagt mir auch nichts.
Bei Step 4 - Options war das "verify after programming" nicht anwählbar, auch nicht "execute".
Jetzt steh ich wieder hilflos rum!
holger1
 
Posts: 13
Joined: Fri Jan 03, 2014 1:50 pm

Postby r_leilich » Thu May 31, 2007 12:00 am

Hallo,

mir geht es exakt so wie holger1!

Begeistert einen RFID-Reader bestellt und dann ein solches nicht funktionierendes Bastelprojekt erhalten!

Warum gibt es da keine ORDENTLICHE und AUSFÜHRLICHE Beschreibungen seitens Elektor???
Ich meine damit nicht die Beschreibungen der Tools der Chiphersteller. Bei Flash Magic ist ein 100-Seitiges Manual dabei. FTDI liefert auch eine ausfühliche Beschreibung.

ABER: Wie ich das sehe ist doch "Mifare Magic" nur ein Beispielprogramm um die Kommunikation mit dem Leser aufzuzeigen. Und die Firmware des Lesers kann man anscheinend auch in verschiedene Modi versetzen. Wiso muß ich nun mühsam die Visual-Basic-Zeilen durchgehen um die Funktionsweise und das Datenprotokoll zum Leser herauszufinden???
(Artikel:... "einfaches serielles Protokoll"... Und die Protokollbeschreibung???)

Wieso gibt es da keine Beschreibung??
Alles muß man sich da selbst zusammensuchen (z.B. die Information, wie man die FTD2XX.dll anspricht und daß es dazu eine Headerdatei im Ordner des Treibers gibt)

Ist das ein Projekt nach dem Motto "Erstellt - rausgehauen - und dann nach sechs Monaten vergessen" oder warum wird anscheinend die Software trotz reger Tätigkeit im Forum nicht weiterentwickelt? (jüngste Datei vom 14.9.2006)

Grüße
Rüdiger
r_leilich
 
Posts: 3
Joined: Fri Jan 03, 2014 2:03 pm

Postby r_leilich » Thu May 31, 2007 12:00 am

Kann denn keiner was dazu sagen???
157 haben bereits mitgelesen - die elektor Redaktion scheint ja auch zeitnah mitzulesen, wie man am Posting von Sascha_G vom 10.3 16:22 erkennen kann (18:18 Rückmeldung)

Nochmal:
Flash Magic meldet immer folgende Fehlermeldung:
"Unable to connect at the specified baudrate. Try reducing the baudrate. Reset the hardware into ISP mode again."
EGAL bei welcher Baudrate (auch 600 oder 300 oder 115200 ...). Bei "ISP -> Device Configuration..." als auch bei Button "Start" mit eingestelltem Orginal-Hexfile. Ich habe es auf verschiedenen Rechnern probiert, auf unterschiedlichen USB-Ports. Ebenso mit verschiedenen Versionen von Flash Magic.
Ein Neuflashen ist also, weshalb auch immer, nicht möglich! Was könnte da noch der Grund sein?

@Gerhard: bei mir tritt der "Error: 0xF00 Incorrect Serial Frame" auf, wenn ich auf "read all" drücke. Die Statusleiste zeigt "Reader Connected".
Schreiben funktioniert nicht, und wenn Lesen funktioniert, bringt es IMMER eine Reihe Nuller!
Entschuldige, wenn Du dich bei obigem Beitrag persönlich angegriffen fühlen solltest - aber ich erwarte eigentlich bei einem solchem großem und ansonsten auch gutem Elektor-Beitrag auch etwas mehr Dokumentation.

Zitat:
Folgende Sequenz muss mit der Elektor Karte immer funktionieren:

1.) Reader mit dem USB Port verbinden
2.) Mifare Magic starten
3.) Magic - Mifare Ultra Light Fenster öffnen
4.) Karte auf den Reader legen
5.) Button “HF Reset”
6.) Button “Activate Card”
7.) Button “Read All”

bringt bei mir:
RF RESET
Activate Card (REQA-AC-SEL) <- Card with UID: activated

Read Page 0 to 3 <- Error: 0xF00 Incorrect Serial Frame
Read Page 4 to 7 <- Error: 0xF00 Incorrect Serial Frame
Read Page 8 to 11 <- Error: 0x1 No Card present
Read Page 12 to 15 <- Error: 0xF00 Incorrect Serial Frame

und unter "Card Type" steht "Unknown IC Type"

Drücke ich 2x "Activate Card" kommt:
RF RESET
Activate Card (REQA-AC-SEL) <- Card with UID: activated
Activate Card (REQA-AC-SEL) <- Card with UID: 04 77 06 AC activated

Read Page 0 to 3 <- Error: 0x1 No Card present
Read Page 4 to 7 <- Error: 0xF00 Incorrect Serial Frame
Read Page 8 to 11 <- Error: 0x1 No Card present
Read Page 12 to 15 <- Error: 0xF00 Incorrect Serial Frame

Da scheint was Ping-Pong zu spielen!

Ist der Leser Schrott???
Kann das sein, daß da eine ganze Reihe von Lesern "defekt" ausgeliefert wurde? (nach den Forumsbeiträgen mußten ja anscheinend viele den frisch gelieferten Leser vor Erstgebrauch erst mal Flashen?)

Bitte um Antworten
Rüdiger
r_leilich
 
Posts: 3
Joined: Fri Jan 03, 2014 2:03 pm

Postby allu » Thu May 31, 2007 12:00 am

Guten Tag,

bei meinem Reader war im Lieferzustand der falsche (interne) Oszillator einprogrammiert. Das führte dann reihenweise zur Meldung "<- Error: 0xF00 Incorrect Serial Frame".

Wie der externe Quarz mit der korrekten Frequenz ausgewählt werden kann hat Gerhard am 17.11.2006 19:02:07 unter den Thema: "Error: 0xF00 Incorrect Serial Frame" beschrieben. Bei mir ist der Betrag zur Zeit ganz oben auf der 2. Forumsseite und dort wieder auf der zweiten Seite zu finden.

Nachdem ich nach dieser Anleitung den Quarzoszillator angeschaltet hatte, funktionierte der Reader (vielen Dank noch mal an Gerhard) - allerdings nur mit so mit maximal 1,5 cm Reichweite. Zu diesem Zeitpunkt war bei der Auslieferung die Antenne noch falsch abgestimmt (siehe Thema Reichweite). Dies soll aber laut Elektor inzwischen behoben sein.

Nach einigen Tagen kam das nächste Problem: nichts ging mehr, nur noch dunkle Blöcke auch der Anzeige. Nach der Neuprogrammierung des Prozessors lief der Reader dann endlich.

Um die Hintergrundbeleuchtung des Displays nutzen zu können. habe ich mich dann für ausschließlichen Betrieb am USB-Port entschieden. Natürlich geht auch eine geregelte Gleichspannung. Wie es geht steht unter Displaybeleuchtung, Stromversorgung.

Viel Erfolg bei der Fehlerbehebung und freundliche Grüsse
Alex
allu
 
Posts: 17
Joined: Fri Jan 03, 2014 1:59 pm

Postby r_leilich » Thu May 31, 2007 12:00 am

Hallo Alex,

danke für die Antwort, es scheint wirklich an dem internen Oszillator zu liegen.
Aber, wie ich oben schon geschrieben habe: der Reader lässt sich mit Flash Magic NICHT umprogrammieren!

Die Stromaufnahme habe ich auch kontrolliert - sie liegt bei ca. 77 mA und damit im Sollbereich.

Ich habe Elektor angerufen und wir sind zu dem Schluß gekommen, daß der Reader eingeschickt werden muß - der Bootloader funktioniert anscheinend nicht, so daß Flash Magic keine Kommunikation mit dem Reader hinbekommt.

Gestern habe ich das Teil abgeschickt - ich bin mal gespannt, wie lange die "Reparatur" dauert.

Mir ist zu Ohren gekommen, daß Elektor massive Probleme mit der Platine hat. Es wurden anscheinend die meisten, wenn nicht sogar alle Platinen falsch programmiert ausgeliefert. Stimmt das? Wer hat eine auf Anhieb fehlerfreie Platine erhalten?

Displaybeleuchtung: Habe ich bisher noch nicht ausprobiert, das beleuchtete Display wurde erst gestern nachgeliefert; bei meinen Tests habe ich ein altes STN Display verwendet, Anschlüsse sind ja baugleich.
Aber: der LPC936 hat 8 Pins, die auf Lötaugen geführt sind und zur freien Verfügung stehen. Da hätte man doch gleich einen zum Aktivieren der Displaybeleuchtung nehmen können!

Mifare Magic in der Version 2.0 hat eine "Access Control" - Seite, auf der bis zu 10 Karten und 6 Texte für eine "Zugangskontrolle" in das EEPROM des Readers einprogrammiert werden können.
Was da noch viel interessanter wäre: den Reader als "mobiles Zeiterfassungssystem" zu verwenden. Kommerzielle Versionen eines solchen Geräts kosten da 300 bis 900 Euro! Dazu müsste man sinnvollerweise einen weiteren Port auf einen Beeper legen und 3 Ports auf Taster "kommen" "gehen" und "Dienstgang". Hat einer schon mal so was versucht?

Rüdiger
r_leilich
 
Posts: 3
Joined: Fri Jan 03, 2014 2:03 pm

Next

Return to RFID-Projekte

Who is online

Users browsing this forum: No registered users and 1 guest