Software(probleme) bei Installation, mit Compiler, Debugger

Postby wolletz » Thu May 31, 2007 12:00 am

moin moin,

lese schon seit geraumer Zeit hier mit im Forum und wollte mich nun selber mal ransetzen. Da ergibt sich nur ein kleines Problem beim ersten Schritt:

Der Debugger KD30 lässt sich nicht installieren.
habe getestet:
- die version von der CD
- die neueste version von renesas

mein os is win2k sp4

die installation hängt sich auf, wenn der install shield wizard bei 100% steht..(bei beiden versionen)
neustart hat auch nix gebracht

hilfe...

mfg Wolle

€dit: kann ich auch KD3038 verwenden? der lässt sich installieren

€dit2: Wird man hier geholfen oder im Regen stehen gelassen? Habe noch keine Lösung gefunden...
wolletz
 
Posts: 1
Joined: Fri Jan 03, 2014 1:49 pm

Postby dye334 » Thu May 31, 2007 12:00 am

Hallo,

ich habe ein Problem mit der HEW-Software. Und zwar habe ich in der oberen Leiste kein "Build", welches eigendlich zwischen "Project" und "Debug" stehen sollte.
dye334
 
Posts: 1
Joined: Fri Jan 03, 2014 1:49 pm

Postby apokorny » Fri Jul 27, 2007 12:00 am

@WolleTz

Nein, man wird nicht im Regen stehen lassen! In der Vergangenheit war es öfters so, dass User mit Win2k Probleme hatten. Leider gibt es dafür bis heute keine Lösung. Renesas selbst empfiehlt WinXP.

Den KD308 kannst Du leider nicht verwenden, da er für die M32C/8x Serie ist (32-Bit).

Bei manchen leuten hat geholfen alles runter und noch mal neu anfangen.

Sorry

apokorny
apokorny
 
Posts: 122
Joined: Fri Jan 03, 2014 1:49 pm

Postby apokorny » Fri Jul 27, 2007 12:00 am

@ dye334

leider schein es bei der Installation Probleme gegeben zu haben. Auch Dir rate ich runter und neu drauf!

Apokorny
apokorny
 
Posts: 122
Joined: Fri Jan 03, 2014 1:49 pm

Postby inelson » Sun Jul 29, 2007 12:00 am

Hallo,

ich versuche gerade ein ca 20kB großes Programm (viele Strings) mittels des auf der Renesas Seite erhältlichen Tools "Flash Start" in meinen R8C/24 (32kB ROM) zu laden, jedoch ohne Erfolg. Dummerweise erhalte ich rein gar keine Fehlermeldung, werder in HEW noch über Flash Start.
Solange das Programm die 8kB Marke nicht überschreitet, funktioniert es. Die entsprechenden Zeilen bezüglich des Near Rom Code habe ich in der sect30.inc bereits auf 0x8000H angepasst, jedoch ebenfalls ohne Erfolg.
Hat irgendwer ähnliche Erfahrungen gemacht, oder eine Idee, wie das Problem zu lösen ist?
Danke
inelson.
inelson
 
Posts: 2
Joined: Fri Jan 03, 2014 1:49 pm

Postby inelson » Tue Jul 31, 2007 12:00 am

Hallo

ich konnte das Problem mit einem neuen Controller vom selben Typ lösen. Scheinbar waren Bereiche im Speicher defekt, dass sich das Programm nicht ausführen ließ. Allerdings muss auch beim R8C/24 erst die sec30.inc angepasst werden um die vollen 32kB nutzen zu können.

Eine Frage hätte ich dennoch an dieser Stelle bezüglich der Programmgröße. Wo kann ich erkennen, welchen Platz mein Programm letztlich im Controller benötigt? Die Angaben aus HEW weichen in ihrer Vielzahl doch deutlich von denen aus dem Windows Explorer ab.
inelson
 
Posts: 2
Joined: Fri Jan 03, 2014 1:49 pm

Postby guenopa » Fri Sep 28, 2007 12:00 am

Ich habe ein gekauftes Board und was funktioniert, die LED mit der Anzeige Betriebsspannung vorhanden und die
Beleuchtung im graph. Display. Eine jegliche programmierung versagten bisher , warum ,weil alle Angaben und Hilfen nur in englisch vorhanden sind. Suche eine Bedienungsanleitung in deutscher Sprache.
guenopa
 
Posts: 10
Joined: Fri Jan 03, 2014 1:49 pm

Postby guenopa » Fri Sep 28, 2007 12:00 am

Es ist fast schon kriminell dass uns eine solche Anlage verkauft wird ohne einer Bedienungsanleitung in deutscher Sprache. Die angegebenen Experten sind alle Deutsche, es sollte doch möglichn sein , dass mal einer auf die Idee kommt, was deutsches über diesen R8C zu schreiben. ich warte schon etliche Monate auf so ein Ereignis.
guenopa
 
Posts: 10
Joined: Fri Jan 03, 2014 1:49 pm

Postby andreas2048 » Fri Sep 28, 2007 12:00 am

Hallo Günter,

ich habe auch prinzipiell einige Probleme damit, das man in Deutschland wie selbstverständlich voraussetzt, das man im Alltag die englische Sprache beherrscht (obwohl ich sie recht gut beherrsche). Was das Elektorboard betrifft, so glaube ich, das du etwas überreagiert hast. Kennst du schon diesen Link http://www.elexs.de/mikros/r8c13.htm ?
Im übrigen ist für dieses Jahr noch ein Buch des Elektorverlages mit 240 Seiten zum R8C angekündigt.

Was klappt denn nicht bei dir? Es sollte doch im Forum bereits jede Menge Antworten geben. Wenn ein ungenanntes Problem auftaucht, so schreib es einfach mal kurz in einem neuen Thread auf. Es findet sich bestimmt jemand der helfen kann.

Andreas
andreas2048
 
Posts: 110
Joined: Fri Jan 03, 2014 1:47 pm

Postby guenopa » Fri Sep 28, 2007 12:00 am

Hallo Andreas, Danke für das Hilfsangebot. Will mit dem FDT das Programm port_toggle testen und es kommt immer die Fehlermeldung Error No 15026. Welche anderen fertigen Testprogramme sind zu empfehlen ?
Danke im voraus , Günter
guenopa
 
Posts: 10
Joined: Fri Jan 03, 2014 1:49 pm

PreviousNext

Return to Das R8C-Projekt

Who is online

Users browsing this forum: No registered users and 1 guest