VFD-Shield

Nicht fluchen – Hilfe suchen

VFD-Shield

Postby l_a_s_t » Mon Dec 05, 2016 10:17 am

Hallo, ich habe das VFD-Shield aus September 2015 (Bausatz) geschenkt bekommen und aufgebaut.
Ich habe die Demo-Software aufgespielt und prinzipiell funktioniert es auch. Ein paar Zahlen bekomme ich angezeigt,
bei anderen erscheint "nur" eine 8 (alle Segmente aktiv) mein Versuch das zu verlangsamen hat nicht geklappt.
Hat jemand einen Tipp wo ich ansetzen muss oder eine eigene Software, die funktioniert?
l_a_s_t
 
Posts: 58
Joined: Fri Jan 03, 2014 1:57 pm

Re: VFD-Shield

Postby i2c » Tue Jan 03, 2017 10:06 am

Welchen Arduino verwendest Du? Die Port-Pins werden beim Durchscannen zur Ansteuerung der VFDs in Schleifen hochgezählt - das ist low-level und umgeht die Definitionen, die in den einzelnen Arduino-Typen-Beschreibungen abgelegt sind.
Ich hab' das bei Versuchen mit "Nicht-Unos" herausgefunden und teilweise abgefangen. Der Leonardo (und auch der Mega 2560) machen Ärger, weil die Ports digital 2 .. 9 intern nicht nacheinander kommen.

Wenn Du einen UNO hast, probier es mal damit, das ist am einfachsten.

Gruß, Wolfram
i2c
 
Posts: 102
Joined: Fri Jan 03, 2014 1:49 pm

Re: VFD-Shield

Postby HGB100 » Sun Jan 08, 2017 12:15 pm

Habe mir auch das Gerät zusammengebaut. Das Testprogramm läuft einwandfrei. Aber wenn ich das Uhrenprogramm lade, bekomme ich immer eine Fehlermeldung.
Ich muß wahrscheinlich im Programm die Uhrzeit eingeben, aber wo ?

Vielleicht kann mir jemand helfen

Gruß
-Horst
HGB100
 
Posts: 2
Joined: Sun Jan 08, 2017 11:54 am

Re: VFD-Shield

Postby l_a_s_t » Tue Sep 26, 2017 9:13 am

nach langer Zeit kurze Korrektur: Hatte einen NPN und einen PNP vertauscht, jetzt sind alle Zahlen korrekt zu erkennen.
l_a_s_t
 
Posts: 58
Joined: Fri Jan 03, 2014 1:57 pm


Return to Meine Schaltung funktioniert (noch) nicht :-(

Who is online

Users browsing this forum: No registered users and 3 guests