ICD2

Postby phillou » Wed May 30, 2007 12:00 am

Bonjour à tous.

Je voudrais connecter mon programmateur MATRIX sur mon P.C. pour exploiter l' ICD2 avec MPLAB.
Quel fiches faut-il placer sur la carte EB-006-00-4

Merci davance.

phillou
 
Posts: 18
Joined: Mon Jan 20, 2014 8:01 am

Postby phil307 » Tue Oct 16, 2007 12:00 am

Je voulais savoir si quelqu' un a déjà mis en oeuvre ce modèle (voir http://www.virtualvillage.fr/Items/006401-001?sck=224654 ) avec le programmateur matrix pour PIC en mode debug?

Merci pour votre réponse
phil307
 
Posts: 44
Joined: Mon Jan 20, 2014 8:01 am

Postby jluc69001 » Tue Jan 08, 2008 12:00 am

Bonjour

oui j'ai eu l'occasion. Il marche tres bien en RS232C.
Par contre pas du tout en USB.
Ils conseillent de mettre à jour le bootloader du 18F4550 (fourni sur un site qu'ils communiquent avec la bête mais ils se gardent bien de le faire avant d'envoyer le truc...), et je n'y suis jamais arrivé (PIC HS au bout de 10 mn d'utilisation ?).
On demande des conseils et ils repondent qu'il faut mettre à jour le bootloader. On demande comment faire précisément puisque le pic n'est pas reconnu et il conseille d'utiliser un ICD2 de regarder la doc microchip.
Au bout de 2 mails ils ne repondent plus.
En gros ca semble pas cher, mais on achete un icd2 pas au point en usb mais qui fonctionne en RS232.
Donc tres lent pour le debuggage.
Je déconseille. A moins de contre-exemples ....
jluc69001
 
Posts: 1
Joined: Mon Jan 20, 2014 8:01 am

Postby lion » Wed Feb 25, 2009 12:00 am

Bonjour,comme le dit jluc69001 celà n'est pas sérieux je n'arrive pas à brûler un programme dans un pic16f88 ,j'ai toujours la même réponse apres de multiple configuration de config1????
lion
 
Posts: 254
Joined: Fri Jan 17, 2014 4:34 pm

Postby ymasquel » Wed Feb 25, 2009 12:00 am

Bonjour à tous,

J'ai suivi le lien indiqué par "Phil307". J'ai jeté un oeil au descriptif et j'ai lu : "Alimenté USB 2.0 pour plus de rapidité".

Je ne serais pas totalement surpris si le matériel n'est prévu que pour communiquer en mode RS232 et que la prise USB n'existe que pour assurer l'alimentation électrique du programmateur (si, si, j'ai déjà vu cela!).

Pour avancer un peu, y a-t-il une réaction de windows lors du branchement du programmateur (nouveau matériel détecté) ? Si ce n'est pas le cas c'est que vraiment la connectique USB ne sert qu'à l'alimentation.

Amicalement, Yves.
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3362
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby lion » Thu Feb 26, 2009 12:00 am

Bonjour, pour ma part j'ai essayé le pic16f88,cela n'a pas fonctionné, je suis passé sur un 18f2520 le programmateur a trés bien fonctionné le tous en USB.Puis j'ai refait l'essai avec 16f88 et c'est la misère toujours en USB ??? Merçi. Elie
lion
 
Posts: 254
Joined: Fri Jan 17, 2014 4:34 pm

Postby ymasquel » Thu Feb 26, 2009 12:00 am

Bonjour à Elie et aux autres,

Pour certaines puces comme le PIC16F88 il y a partage des broches entre plusieurs fonctions (c'est d'ailleurs une généralité).

Mais dans le cas du PIC16F88 ce partage concerne l'usage du timer1 comme horloge temps réel avec un quartz de 32,... kHz sur les pins RB6 et RB7.

Cette cohabitation est néfaste avec une programmation ICSP (voir dans la fiche technique la note en encadré page 147 et en tête de la description de l'utilisation du timer 1 en oscillateur).

Il n'est pas indiqué que TIOSCEN doit être à ZERO (clear) mais cela ne me surprendrait pas.

Ce n'est qu'une piste... Vous n'avez pas donné d'infos sur le contexte de fonctionnement du circuit.

Amicalement, Yves.
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3362
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby lion » Thu Mar 05, 2009 12:00 am

Bonjour et merçi Yves.Le programme que je désire n'est pas de moi,mais de Siliconchip une revue Australienne.Voilà la cofiguration: list p= 16f88 #include p16f88.inc ERRORLEVEL - 302 ERRORLEVEL - 306
Program Configuration Register 1
CONFIG CONFIG1, CP ALL & CCP1 RBO & DEBUG OFF &WRT PROTECT OFF & CPD OFF & LVP OFF & BODEN ON & MCLR ON & PWRTE ON & WDT OFF & HC OSC.
Program Configuration Register 2
CONFIG CONFIG2, IESO OFF & FCMEN OFF.
L'EEPROM est programmée ,mais le register 1 a que des zéros.A l'effacement tout est correcte 3FFF.et le programme affiche par moment prog. et vérification reussi????et la lecture donne que des zéros sauf l'eeprom ou c'est correct. Salutations. Elie
lion
 
Posts: 254
Joined: Fri Jan 17, 2014 4:34 pm

Postby ymasquel » Thu Mar 05, 2009 12:00 am

Bonjour Elie,

Si ton registre de configuration 1 commence par CP ALL il est normal que tu obtiennes des ZEROS à la relecture de la mémoire programme mais je te laisse chercher pourquoi. Tu passes un message sur le forum pour dire si tu as trouvé ou, dans le cas contraire, pour obtenir une réponse.

Amicalement, Yves.
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3362
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby lion » Sat Mar 07, 2009 12:00 am

Bonjour Yves et merçi.C'est Siliconchip qui préconise CP ALL,mais ce qui me préocupe c'est CCP1 RB0.J'ai essayé CCP1 RB3 cela n'a rien changé. Salutations Elie
lion
 
Posts: 254
Joined: Fri Jan 17, 2014 4:34 pm

Next

Return to E-blocks

Who is online

Users browsing this forum: No registered users and 1 guest