Traceur de courbes de transistors Elektor février 2009

Postby processeur fou » Mon Jun 15, 2009 12:00 am

Bonjour Yves,
Merci de cette réponse rapide. Je veux d'abord vérifier si je ne suis pas passé à coté de quelque chose avant de contacter le SAV d'Elektor. Donc voir si qqun n'a pas eu le même problème et trouvé l'origine ou tout simplement détecte une erreur de ma part. Bien sûr je pense à des conflits mais c'est vague, surtout quand j'ai le même phénomène sur 3 PC différents, qui n'ont pas la même carte mère etc.. donc je doute du conflit répétitif. Pour moi l'utilisation de cette carte à ce premier niveau est basique, la carte est livrée montée, l'alim est fournie par l'USB, mon montage de l'autre carte n'intervient pas encore ( et les 2 cartes ne sont pas encore reliées). Donc j'en suis à la première étape : installer le pilote du convertisseur USB série, attendre qu'il détecte la carte, lui donne un n° de port COM et dise OK. Mais je n'ai pas de OK!! Je vais essayer peut -être avec win2000 desfois que ce soit mieux géré??. A suivre.
JP
processeur fou
 
Posts: 6
Joined: Fri Jan 17, 2014 4:38 pm

Postby ymasquel » Tue Jun 16, 2009 12:00 am

Bonjour "JP",

Tu dis que tu as utilisé la dernière version de pilote de prolific mais, est-ce la bonne option ?

Le montage d'origine de la partie contrôleur/interface USB RS232 pouvait être en relation avec le PC grâce à un pilote fourni sur le site de la revue sous la référence 050179-3-11.zip .

Il serait peut-être intéressant d'essayer cette version après avoir désinstallé les versions plus récentes par précaution.

Amicalement, Yves.'
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3362
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby processeur fou » Tue Jun 16, 2009 12:00 am

Bonjour,
Merci mille fois Yves! En effet cette version fonctionne tout de suite ( après bien sûr avoir enlevé la précédente).
Pourtant c'est une version plus ancienne (version 2.0.2.1 du 25 juillet 2005), alors que la version + récente ( version 2.0.5.111 du 4 janvier 2009) disponible sur le site du fabriquant ne fonctionne pas sous XP SP3. Peut-être qu'ils l'ont fait évoluer pour Vista mais maintenant elle ne marche plus sous XP!
C'est une bonne chose de le savoir, d'autre risquent de se faire attraper...
et heureusement qu'il y avait cette vieille version sur le site elektor, car je n'ai vu que la version récente sur le site Prolific. ( à l'adresse que tu avis inscrit dans ce sujet sur ton message précédent du 08-04-2009).
J'ai beau ausculter à nouveau leur site je ne vois pour Windows que le nouveau driver.
Bref on a le bon.
Je n'aurai pas pensé à fouiller pour trouver ce pilote avec un montage de mars 2006...
Merci.
JP
processeur fou
 
Posts: 6
Joined: Fri Jan 17, 2014 4:38 pm

Postby ymasquel » Tue Jun 16, 2009 12:00 am

Bonjour JP,

L'article décrivant le traceur de courbes faisait explicitement mention d'une parenté avec le schéma utilisé en mars 2006 "camp de base pour débutants".
Une comparaison entre le schéma de l'époque et celui de la partie "numérique" du traceur de courbes montre plus qu'une parenté.
Une petite exploration des ressources disponibles concernant le montage de 2006 a vite fait apparaître l'existence du pilote dans les softs disponibles.
Aucune plainte sérieuse concernant la connectivité du "camp de base" n'avait été émise sur le forum. Seules quelques broutilles qu'on peut corriger en modifiant le paramétrage FIFO ou en réinstallant correctement les pilotes.
De ces constatations j'ai pu te conseiller d'utiliser cette version qui n'avait que peu de raisons de ne pas fonctionner.

Le package de pilotes disponible sur le site de Prolific contient les versions les plus récentes pour (à peu près) toutes les versions de systèmes d'exploitation (ainsi que pour windows serais-je tenté de dire). Mais à trop vouloir en faire il y a parfois des situations simples qu'on dégrade.

Le principal est que ton problème est résolu. Il reste maintenant à voir la partie analogique pour laquelle il y a quelques messages sur le forum.

Amicalement, Yves.
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3362
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby processeur fou » Tue Jun 16, 2009 12:00 am

oui, après coup j'ai repensé à cet article de mars 2006- mais je pensais qu'il était surtout sur le RC8/13 et pas forcément équipé aussi avec un PL2303.
Sinon premiers essais faits, j'ai bien mes courbes avec un PNP BC557 et avec les valeur UVE sans problème en abscisse ( pour répondre au collègue qui a des problèmes avec les PNP et les valeurs en abscisse.)
A suivre...
JP
processeur fou
 
Posts: 6
Joined: Fri Jan 17, 2014 4:38 pm

Postby etoile91 » Thu Jun 25, 2009 12:00 am

Bonjour,

Je vois que c'est toujours la même galère pour installer un bout de composant Usb. Ils ne font toujours pas de documentation digne de ce nom sous prétexte que chercher est éducatif! Ce qui est sûr est que cela ne leur coûte pas chère.
J'ai 3 problèmes:
- où trouver les composants (DG441DJ) facilement pour la platine analogique?
- leur driver ne semble pas s'installer sous Windows Vista Sp2,
j'ai réussi à installer Usb Serial Converter comme pilote. Je ne sais pas si celà est le bon.
- Après avoir lancé le chargement du firmware, et sélectionné le port, je suis bloqué sur la fenêtre ID Check. J'ai sélectionné le type R8C, le chemin de CurbeTracer.mot mais il me manque l'ID.
Où trouver ce renseignement?

Merci aux courageux.
etoile91
 
Posts: 25
Joined: Fri Jan 17, 2014 4:35 pm

Postby processeur fou » Thu Jun 25, 2009 12:00 am

Bonjour,
j'ai trouvé le DG441DJ chez le petit marchand de Poitiers et j'en ai aussi commandé chez Farnell.
Le driver pour Vista semble être celui du site Profilic, pour XP que j'utilise ul ne fonctionnait pas. J'ai alors utilisé le driver mis à disposition sur le site Elektor.
C'est bien l'USB seriel driver qu'il faut utiliser.
On voit que l'on a mis le bon pilote quand dans le gestionnaire de périphérique apparait un nouveau port COM (COM3 ou COM12...)
C'est celui là que détectera le soft.
Dès que j'ai eu mis ce bon pilote alors tout s'est mis à fonctionner (dans tous les modes que j'ai pu essayer) sans problème.
pour que l'ID check fonctionne il faut avoir ce nouveau^port COM installé et en étét de bon fonctionnement.
On peut tester le module USB avant d'avoir monté la platine analogique.
Bon courage.
JP
processeur fou
 
Posts: 6
Joined: Fri Jan 17, 2014 4:38 pm

Postby etoile91 » Fri Jun 26, 2009 12:00 am

Bonjour,

Il est toujours impossible d'installer les drivers PL-2303 ou Prolific dernière version, sur Vista SP2 sur Asus Dual Core 2 ou sur Windows 7 sur Gygabyte Quad Core 2. Je ne sais comment ils testent leur pilote mais les résultats sont nuls.
Par contre aucun problèmeavec Xp sur Asus NoteBook.
Merci pour votre aide.

Au plaisir de vous lire.
etoile91
 
Posts: 25
Joined: Fri Jan 17, 2014 4:35 pm

Postby etoile91 » Tue Jun 30, 2009 12:00 am

Le Driver 050179-3-11, PL-2302 Driver Installer.exe, téléchargé sur le site Elektor ne fonctionne pas sous Vista32 SP2 pas plus que sous Windows 7 version RC. Par contre il fonctionne bien sur windows Xp.

Le Driver de chez Prolific PL-2303X pour Vista32 ne fonctionne pas non plus. Je crois qu'en logiciel Elektor gère mal le composant d'interface PL 2303X.

Dans le firmware, le fichier Curve_Tracer.mot ne comporte pas l'Identificateur nécessaire pour recharger une nouvelle fois le Firmware.

En définitive, cela est comme d'habitude chez Elektor dès qu'il s'agit d'USB il vende des produits qui ne sont pas finis.

De plus, CurveTrcer V1.2, ne peut pas ce désinstaller!
etoile91
 
Posts: 25
Joined: Fri Jan 17, 2014 4:35 pm

Postby hp-elektor » Thu Jul 02, 2009 12:00 am

Bonjour,

Je suis cette discussion depuis quelques temps car je rencontre de nombreux problèmes avec des adaptateurs USB-RS232 utilisant le circuit PL2303 de Prolific.

N'ayant vu ni schéma(s) ni code(s) source, je ne me prononcerai donc que sur l'aspect purement drivers de ce circuit.

Personnellement, j'ai eu à faire fonctionner ce grincheux adaptateur USB-RS232 avec MS-Windows Vista Home (FR), on a finalement abandonné car les numéros de port COM étaient trop aléatoires entre déconnection et reconnection des adaptateurs durant un même allumage de la machine ou entre deux allumages-extinctions. C'est pour un système de navigation gérant plusieurs sources GPS (un impératif de sécurité).

Après être revenu à MS-Windows XP Pro (FR), ce même adaptateur continue de faire des siennes.
Le fabricant est ConnectLand ("no comment", c'est pour raisons de tests...).
Prolific semble avoir une liste de fabricants de "cordons" USB-RS232 utilisant leurs circuits recommandés (voir ici : http://www.prolific.com.tw/eng/downloads.asp?ID=31, qprès le premier lien de téléchargement de fichier ZIP (=PL2303_Prolific_DriverInstaller_10311.zip)).

Peut-être déjà vérifier, si cela est possible, que lon possède bien un produit assemblé par l'un des fabricants cités.
Personnellement, je n'ai effectivement eu aucun problème avec un convertisseur de chez ATEN acheté il y plus de 5 ans (a même fonctionné sous MS-Windows Mellenium, c'est pour dire...) qui, a ma grande surprise, est équipé avec le Chip PL2303.

Voir aussi le commentaire en bas de pas à cette adresse : http://www.prolific.com.tw/eng/download.asp


Cordialement,
HP



P.S.
Pour ce qui du montage proposé, sil y a un PL2303 de soudé sur le PCB je recommanderais donc :
- soit de bien lire toutes les notes d'applications et DataSheets de Prolific
- sinon, de passer à FTDI avec notamment le FT232RL qui peut se passer d'un coûteux quartz si l'on travail à 9600 bps. (pas vérifier à d'autres débits)'
hp-elektor
 
Posts: 12
Joined: Fri Jan 17, 2014 4:36 pm

PreviousNext

Return to R8C/13 (01-2006)

Who is online

Users browsing this forum: No registered users and 1 guest