Conseille pour une moteur pas à pas

Questions générales... en particulier !

Postby 0zmax » Mon Feb 17, 2014 12:00 am

Merci de vos réponses

Je vais complété les infos sur lapplication. Je suis déjà entrain de la coder. J'utilise pour ça le kit launchpad MSP430 (série G2). Le moteur pas à pas que j'utilise pour faire mes tests est un PM42L-048-SGB6 que j'ai utilisé il y a bien fort longtemps quand j'étais encore à l'école secondaire et aucune datasheet n'est trouvable... La seule chose que j'ai trouvé et qui se rapproche de mon moteur est ça :

http://www.nmbtc.com/pdf/motors/PM42L-048-HHC9.pdf

Le circuit de commande utilise un LM293. Tout marche en soit, la camera tourne mais les pas sont trop grand (7,5°) et un pas sur deux génèrent une légère oscillation fort gênante. Même chose en mode demi pas. Cest pour cette raison que je pensais changer le moteur. J'ai l'impression que le miens à beaucoup souffert par mes maladresses d'avant (et même encore de maintenant) ^^' . Et en plus je serai plus à l’aise pour les alimentation avec des moteurs 5V. Donc si je te reprend Gérard, je pourrais donc prendre un moteur cette tension. Et en fait non, je n'avais pas pensé à couper l'alimentation pendant le temps de repos . C'est une bonne idée économe que j'ajouterai à mon code (j'imagine qu'il me faudra un transistor avec diode de roue libre).

En fait, ce qu'il me faut est un moteur pas à pas adapter à mon application. Le 28BYJ-48 que tu m’as montré Yves me semble bon et pas chers mais le pas n’est t’il pas trop élevé ? (1/64). Enfin quand je vois ce genre de test :http://www.youtube.com/watch?v=14jF8umwJLI . Je me demande si avec ma caméra qui pèse 600g je pourrai le faire tourner avec l’axe du moteur orienté verticalement (donc vers le haut) sans problème comme je le fais actuellement ?
0zmax
 
Posts: 23
Joined: Mon Jan 20, 2014 8:05 am

Postby 0zmax » Mon Feb 17, 2014 12:00 am

Quoi que pour le pas, sa fait quand même 8*64 sois 512 demi pas par tour contre 384 avec mon moteur actuel. Donc je pense que se sera un bon début ^^. Reste à savoir le couple.
0zmax
 
Posts: 23
Joined: Mon Jan 20, 2014 8:05 am

Postby ymasquel » Mon Feb 17, 2014 12:00 am

Bonjour Max,

Le moteur dont je te parle est en final un 4096 pas par tour puisqu'il y a 64 pas pour le moteur lui-même et qu'il y a un réducteur à engrenages 1:64.

Compte tenu de ce que tu souhaites faire je crois que "qui peut le plus peut le moins" car rien ne t'empêche de déclencher des mouvements de plusieurs pas à la fois.

En ce qui concerne le couple il faut penser au support de la caméra et au point où sera appliqué l'effort. Si le moteur agit sur un axe équilibré il ne lui faudra que très peu d'effort mais si l'axe est à une extrémité de la caméra il y aura tout le poids de celle-ci à porter et déplacer (essaie un peu de réaliser un mouvement de traveling vertical à un balai en le tenant à l'extrémité du manche ou en son milieu!). Le lien que tu fournis est parfait pour illustrer une partie de mon propos. Si tu mets 500g de chaque côté le moteur n'aura aucune peine à effectuer le mouvement.

ATTENTION!!!!!! Le LAUNCHPAD MSP-EXP430G2 qui utilise le MSP430G2553 ou un autre fonctionne avec une tension d'alimentation de 1,8 à 3,6V. En principe ça devrait fonctionner avec le driver du moteur mais à vérifier.

Amicalement, Yves.
Amicalement,
Yves.
ymasquel
Site Admin
 
Posts: 3364
Joined: Thu Jan 02, 2014 10:44 am
Location: Oise (60)

Postby 0zmax » Tue Feb 18, 2014 12:00 am

Merci Yves pour tes précisions. Je pense que je vais expérimenter des essaies avec le moteur 28BYJ-48. Avec le driver LM293, les niveaux logiques 0 - 3,6V du MSP sont bien reconnus. Mais je ne sais pas encore pour le ULN2003. A tester donc

Voilà, merci à tout le monde pour vos conseilles bien guidés.

Maxime
0zmax
 
Posts: 23
Joined: Mon Jan 20, 2014 8:05 am

Previous

Return to Électronique générale.

Who is online

Users browsing this forum: No registered users and 2 guests