OBD2-NG (sept. 2009) Code erreur

Postby dipsy2207 » Thu Mar 04, 2010 12:00 am

Bonjour

Je viens d'effectuer le montage de mon boitier. Tout est ok. Quand je le branche sur ma voiture et que je vais sur information il me donne la tnesion de la batterie.

Par contre quand je lui demande de faire le diag. Je le laisse cherche le protocole de la voiture et la il me repond ERROR 91.

Auriez vous une solution ???

Cordialement
dipsy2207
 
Posts: 9
Joined: Mon Jan 20, 2014 7:53 am

Postby smba38 » Thu Mar 04, 2010 12:00 am

Bonjour,

L'erreur 91 est une erreur indiquant que le kit ne peut dialoguer avec aucun protocole par la prise OBD2.

La valeur de la tension de la batterie n’est pas récupérée par un dialogue OBD2 mais par la tension relevée par le microcontrôleur sur la prise OBD2.

Pour ma part j’ai testé le kit sur deux véhicules.
Sur une clio III diesel tout est OK (Voir mes messages sur ce forum).
Sur un espace IV diesel j’ai aussi une erreur 91, par contre le menu Véhicule identification me donne bien les informations sur l’identification de mon véhicule (voir le premier sujet sur ce forum)..

Les véhicules anciens ne répondent pas tous à tous les protocoles OBD2.

Essayer le kit sur un autre véhicule.

Cordialement.

SMBA38.
smba38
 
Posts: 8
Joined: Mon Jan 20, 2014 7:53 am

Postby smba38 » Fri Mar 05, 2010 12:00 am

Suite du message précédent

J’ai indiqué par erreur que le kit provoque une erreur 91 sur un espace IV DCI.

En fait l’erreur 091 se produit avec le moteur éteint.
Il faut faire tourner le moteur pour que kit détecte le protocole KWP2000 (5- fast init).

Mais avec ce protocole, seule les informations sur l’identification du véhicule sont récupérées.

J’ai jeté un œil dans les sources, Les PIDS retournant des données sur l’identification d’un véhicule sont les PIDS 0902 0904 et 0906.

Toutes les autres informations ne sont pas lues (nb de tour, température etc).

J’ai connecté un terminal ascii sur la prise ISP du kit pour lancer les commandes à la main.

Les PIDs 0902 0904 0906 retourne bien une information mais les autres PIDS ne retournent rien.

Pour les curieux voici la trace du dialogue avec le DXM1 (Commandes AT).

Pour mémoire voici un lien pour la liste des PIDS -> http://en.wikipedia.org/wiki/OBD-II_PIDs

>atdp -> protocole en cours
ISO 14230-4, KWP2000 (Fast Init)

0900 -> liste des pids de type 9 actifs ( 01,02,03,04)
49 00 01 F0 00 00 00

>0901
49 01 05

>0902 -> le seul pid retournant des données sur le code VIN d’identification.
49 02 01 00 00 00 56
49 02 02 46 31 4A 4B
49 02 03 30 48 41 36
49 02 04 33 30 32 35
49 02 05 30 34 31 34

>0903
49 03 08

>0904 -> calibration
49 04 01 00 00 00 00
49 04 02 00 00 30 30
49 04 03 30 30 30 30
49 04 04 30 30 30 30
49 04 05 00 00 00 00
49 04 06 00 00 00 00
49 04 07 00 00 00 00
49 04 08 00 00 00 00

>0905
7F 09 22

>0906
7F 09 22

>0100 ( PID qui doit retourner en binaire la liste des pids de type 1 valides, aucun pid)
41 00 00 00 00 00

>010C
7F 01 12


>0101
7F 01 12

>0102
7F 01 12

>0103
7F 01 12

>atv -> parameter du DXM1 modifiables.
E1 L1 H0 M0 OF0 KW1 SW19 SF00 SB0 (9600)
HEADER: C0 33 F1
WAKEUP: C1 33 F1 3E
CA1 CC1
CAN-BAUD: 00000000
CAN-TXID: 00000000
CAN-RXID: 00000000
CAN-MASK: 00000000
CAN-FLOW: 00000000
FLOWDATA: 00 00 00 00

>at!00
F366405488

>at!01
DXM1-17

>at!10 tension testée par le microcontrôleur DXM1
13.5V

>atbd
07 83 F1 7A 7F 01 12 80 00 00 32 40 87

>atb
07 01
83 F1 7A 7F 01 12 80

>atdp -> protocole en cours
ISO 14230-4, KWP2000 (Fast Init)

Test manuel des autres protocoles, seul le 5 répond.

>atp1
1 = SAE J1850 / PWM

>0100
NO DATA

>atp2
2 = SAE J1850 / VPWM

>0100
NO DATA

>atp3
3 = ISO 9141-2

>0100
SEARCHING...
ERROR (30)

>atp4
4 = ISO 14230-4, KWP2000 (5 Baud Init)

>0902
SEARCHING...
ERROR (30)

>ATP5 -> le seul qui fonctionne.
5 = ISO 14230-4, KWP2000 (Fast Init)

>0902 -> véhicule identification
49 02 01 00 00 00 56
49 02 02 46 31 4A 4B
49 02 03 30 48 41 36
49 02 04 33 30 32 35
49 02 05 30 34 31 34

>atp6
6 = ISO 15765-4, CAN (11/500)

>010C -> vitesse.
ERROR (40)

>atp7
7 = ISO 15765-4, CAN (29/500)

>010C
ERROR (40).

J’ai fait le même test sur une Clio III diesel, c’est le protocole CAN N° 6 qui est détecté et certains codes sont lus (vitesse température, voir les messages précédents).

Cordialement.

SMBA38.
smba38
 
Posts: 8
Joined: Mon Jan 20, 2014 7:53 am

Postby etoile91 » Thu Apr 29, 2010 12:00 am

Bonjour,
Sur l'OBD-2 de 2007, à quoi correspond les variables suivantes

Air Stat: Off,
OBD Sup: EOBD,
Mil Dist: 0 km,
Load PCT: 13%,
MAP: 101 kPa,

Merci
etoile91
 
Posts: 25
Joined: Fri Jan 17, 2014 4:35 pm


Return to Analyseur OBD-2 NG (09-2009)

Who is online

Users browsing this forum: No registered users and 1 guest