KD100 "Communication ERROR" unter Vista

Postby 00andi » Sun May 10, 2009 12:00 am

Hi,

so nachdem nun R32C C-Compiler und HEW unter Vista laufen
haben ich das nächste Problem:
KD100 bricht nach dem Versuch eine Verbindung aufzubauen
mit der Meldung:
Communication ERROR.
Can't accept data.
ERROR(16014)
ab.

Also das diese Toolkette von Renesas so Probleme unter VISTA
macht??? Unter XP hat eigentlich alles soweit funktioniert.

Vielleicht hat ja einer von euch eine Idee.
Danke,

Andi
00andi
 
Posts: 33
Joined: Fri Jan 03, 2014 1:48 pm

Postby 00andi » Sun May 10, 2009 12:00 am

Ok, anscheinend hängt sich der Treiber manchmal auf
dann hilft es wenn man das USB Kabel abzieht und wieder
ansteckt.

Danach hat es funktioniert.

Ich hoffe nur das der E8a Debugger nicht genauso
buggy ist beim debuggen.

Andi
00andi
 
Posts: 33
Joined: Fri Jan 03, 2014 1:48 pm

Postby qwerty » Sat Dec 19, 2009 12:00 am

Darf ich mich ansliesen ?
Habe eine R32C/111 gekauft inclusive eine CD.
Dan habe ich das program KD100 installiert. Die brucke sj5 geofnet und angeschlossen. Die grune led brent. Communikations venster:
MCU = R32C100ABFL.MCU
Port = com3 (kontroliert (Prolific_USB-Driver\Treiber\XP))
Baud rate = 38400

Und dan press "OK".
Meldung "..... copyright 2005......." und nach 3 sec die meldung "comunication error .... error 16014.

USB treiber neu geladen -> fail
USB connector aus.... warten..... einstecken. -> fail

Tja und dan weis ich nichr weiter.
Hat jemand eine losung ??
qwerty
 
Posts: 2
Joined: Fri Jan 03, 2014 1:48 pm

Postby qwerty » Sat Dec 19, 2009 12:00 am

Vergessen zu berichten das ich MS XP auf meine machine drehe.
qwerty
 
Posts: 2
Joined: Fri Jan 03, 2014 1:48 pm

Postby progressio.ch.vu » Wed Jan 12, 2011 12:00 am

Habe genau gleiches Problem wie qwerty. Hat jemand scho einen Lösungsvorschlag? Ich verwende Windows 7 ansonsten alles genau gleich.

Danke für jegliche Hilfe.
progressio.ch.vu
 
Posts: 4
Joined: Fri Jan 03, 2014 1:48 pm

Postby progressio.ch.vu » Wed Jan 12, 2011 12:00 am

Habe genau gleiches Problem wie qwerty. Hat jemand scho einen Lösungsvorschlag? Ich verwende Windows 7 ansonsten alles genau gleich.

Danke für jegliche Hilfe.
progressio.ch.vu
 
Posts: 4
Joined: Fri Jan 03, 2014 1:48 pm

Postby herch » Fri Mar 22, 2013 12:00 am

Hallo,

ich habe die Software für das R32C11 Carrier Board installiert (auf einem neu installierten PC mit Windows XP sowie XP Professional). Flashen funktioniert, das Programm HEW auch.

Mir ist es bisher nicht möglich den Debugger KD100 zu verwenden. Starte ich die Anwendung "kd100.exe" erscheint folgenden Fehlermeldung:
"Communication ERROR. Can't accept data. ERROR(16014)"

Auch aus HEW heraus ist die Verwendung des KD100 nicht möglich, es erscheint ebenso die Fehlermeldung; obwohl ich den KD100 als Debugger eingestellt habe.

Gibt es irgendetwas Besonderes (z.B. bei der Installation) zu beachten?

Gruß

Christian
herch
 
Posts: 52
Joined: Fri Jan 03, 2014 1:48 pm

Postby frankl » Thu Aug 01, 2013 12:00 am

Hallo,
ihr wisst das R32C zuerst mit einer Monitor-Software programmiert werden muss bevor er auf die Anfragen eines KD100 antwortet?
Ohne Monitor geht nichts.
Der Anhang ist ein Monitor-Beispiel für R5F64112
Attachments
Monitor-R5F64112.zip
(0 Bytes) Downloaded 43 times
frankl
 
Posts: 125
Joined: Thu Jan 02, 2014 10:42 am

Postby herch » Fri Aug 02, 2013 12:00 am

Hallo FrankL,
wäre nett, wenn du beschreiben würdest wie man die Monitor Datei auf den R32C111 bekommt. Die Datei "Monitor_R5F64112.zip" scheint leer zu sein.
Gruß
Christian
herch
 
Posts: 52
Joined: Fri Jan 03, 2014 1:48 pm

Postby wollekr » Fri Aug 02, 2013 12:00 am

Hallo,

der Monitor wird mit dem FDT in den R32C111 geschrieben. Dazu muss ein Jumper umgesteckt werden. Siehe auch Elektor 4/2009 "Die 32-bit-Maschine".

MfG,
Wolfgang
Attachments
Monitor.zip
(7.2 KiB) Downloaded 46 times
wollekr
 
Posts: 24
Joined: Fri Jan 03, 2014 1:48 pm

Next

Return to R32C-Projekt

Who is online

Users browsing this forum: No registered users and 1 guest